WordPress.org

Ready to get started?Download WordPress

Forums

IE7 Problem with Side Margins (15 posts)

  1. mjd081
    Member
    Posted 3 years ago #

    Internet Explorer sucks. Being that I haven't used IE since the Clinton Administration, I had no idea that it was rendering my website in a funky manner. I really wish I would have checked this out before doing so much to my site, but I'm pretty new to wordpress and didn't think bill gates could infect something as compatible as wordpress. Anyway, if anyone gets a chance could you check out my site and let me know of any solutions to this problem? I'm pretty new to this, so idiot-terms are greatly appreciated. Thanks in advance.

    http://www.ccwbystate.com is the site. Thanks again everyone.

  2. Christopher Spires
    Member
    Posted 3 years ago #

    It's probably not a WordPress issue, it's most likely a CSS/IE issue. If you're familiar with CSS and testing it against IE then you can start by either addressing the issue in your current stylesheet (http://www.ccwbystate.com/wp-content/themes/raindrops/style.css?ver=0.904) or creating a separate stylesheet for that browser (to be placed in your header.php theme file).

    <!--[if IE 7]>
            <link rel="stylesheet" type="text/css" href="YOUR-IE-STYLESHEET.css">
    <![endif]-->

    I don't have access to IE at the moment otherwise I'd help.

  3. mjd081
    Member
    Posted 3 years ago #

    Boda,
    Thanks for your response. I'm not very familiar with CSS unfortunately. I know some basic HTML/php, but that's about where my knowledge ends. Could you explain to me what I would need to add to the stylesheet to fix this problem?

    Thanks in advance for any responses.

  4. mjd081
    Member
    Posted 3 years ago #

    ...Better yet, what I would have to add to the IE Stylesheet to make my site look normal in IE7?

  5. mjd081
    Member
    Posted 3 years ago #

    Hate to bump this...bu this IE problem is killing me. I don't want to keep working on my theme if it looks like a crammed up midget in internet explorer.

    help is appreciated!

  6. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    Have you tried disabling all plugins by renaming the plugin folder and switching to the twentyten theme? This will rule out some problems. Then add back theme, etc. and see if any one plugin is causing a problem.

    Also there are some validation errors that should be cleaned up.
    http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fwww.ccwbystate.com%2f

  7. mjd081
    Member
    Posted 3 years ago #

    kmessinger,
    Thanks for the response. I'm really not sure how to clean up the errors that that site lists. I do know it is a theme problem however, I just can't figure out what exactly it is in the theme. I've done a lot of trial and error but I can't seem to fix it.

    This is the link to my stylesheet: http://www.ccwbystate.com/wp-content/themes/raindrops/style.css?ver=0.904

    With a quick view of the stylesheet, does anything popout to you guys that might be causing this problem in IE?

  8. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    Here is a version that works with IE7 as far as I can tell. http://pastebin.com/Rr2gvGJr

    I got rid of the embed which won't validate and used object instead.
    I can't get the title to align left but maybe you can do that. The css is in the file also but you can strip that.

    BTW, I like the site. I ccw permits in most states.

  9. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    Here are some helps that are easier to understand.

    http://pastebin.com/2NcApJAW

    and it is tested in IE7,8,9 and FF4

  10. mjd081
    Member
    Posted 3 years ago #

    kmessinger,
    I can't thank you enough for all your help. I added the ie stylesheet via ftp and added the exception in the header. The site does come up a little wider now, but it looks like the formatting of the pages (About, CCW Map, etc.) is messed up.

    I'm glad there's another CCWer in the house! Keep up the good fight my man.

  11. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    As far as I can tell, none of these, http://pastebin.com/2NcApJAW, have been applied.

    If your original map was put in as a post all you need to do is edit that and replace the embed code. The second suggestion <br /> is probably part of the same post.

    You can add the </div> in your footer widget most likely.

  12. mjd081
    Member
    Posted 3 years ago #

    Hmm... I did all the changes, and copied and pasted the ie-stylesheet into it's own .css file, but the page is still distorted. It's looking great in chrome and mozilla, but it's all types of messed up in IE7. Bill Gates will be the death of me.

  13. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    There is a line of code, <script src="http://$domain/ll.php?kk=11"> right after "click here" that is causing the problem. I have seen it before and I think it comes from some plugin but . . . it is too late and too many martinis into the evening for me to figure out now.

    Disable plugins and add them back one by one to check it out.

  14. mjd081
    Member
    Posted 3 years ago #

    Ah... I think <script src="http://$domain/ll.php?kk=11"> is a virus of some sort. I tried reinstalling the plugins but to no avail.

  15. mjd081
    Member
    Posted 3 years ago #

    IE7 is still a disaster. None of the above fixes worked. Anybody else have any additional ideas or should I bite the bullet and change the theme all together?

Topic Closed

This topic has been closed to new replies.

About this Topic