WordPress.org

Ready to get started?Download WordPress

Forums

IE7 post preview display bug (5 posts)

  1. duanelc
    Member
    Posted 7 years ago #

    I'm troubleshooting the preview window in IE7, as for me, it currently looks like this. I think it might be related to this bit of CSS:

    .navigation {
    	display: block;
    	text-align: center;
    	margin-top: 10px;
    	margin-bottom: 60px;
    	}

    IE7 doesn't seem to be treating the "navigation" class as block level; it certainly doesn't seem to be applying the 60px bottom margin. Has anybody seen this bug? Site reference: http://www.moonfireandsun.com

  2. JustinRDev
    Member
    Posted 7 years ago #

    Hmm. I just crawled your site with FF 2 and IE7 and I didn't see any type of problems. Does this only happen when previewing posts?

    I tested Preview inside my 2.2 release and my theme is displaying properly with a double right sidebar.

    I'm also a little curios to see what the code looks like (thats rendered) for that area.

  3. duanelc
    Member
    Posted 7 years ago #

    Yes. In all my testing so far, it only happens in the preview. Only in IE7. Here's a zip file containing the source code for that. I didn't see anything out of order; maybe you will. It's only in posts; not pages.

  4. JustinRDev
    Member
    Posted 7 years ago #

    The first thing I noticed was that there are no P or BR's listed between the Previous Post and Current Post. It's possible that putting a BR right after the Post Class may fix this, but I'll look at this a little more tomorrow if that doesn't fix it - it's late and I'm not functioning very well anymore.

  5. duanelc
    Member
    Posted 7 years ago #

    Well, it looks like I fixed it. All I did was add a 1px border to the ".navigation" class. Now it displays properly in IE7. Anybody out there know why this might be? Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic