WordPress.org

Ready to get started?Download WordPress

Forums

IE Problem but not with Firefox (12 posts)

  1. ryanfusher
    Member
    Posted 5 years ago #

    Hi,
    My blog is up and running. I have one major problem. When you view my blog with IE, the comments section (which is a link) does not show up properly. It just is a box with an X in it. However, in Firefox it shows up fine.

    Also, if you try and post comments with IE, it will not let you. However, with Firefox, everything is perfect.

    Can someone help me? The guy who made the theme claims everything works fine, but he is wrong. I am getting emails from people asking me what the problem is! My website is http://www.politicalpunt.com

    Thanks,
    Ryan

  2. suprchunk
    Member
    Posted 5 years ago #

    I can click on the link and be taken to the comment block in IE. However the image is not showing up. Are you sure that

    http://www.politicalpunt.com/wp-content/themes/JTksIndyDay2/images/comment_new.gif
    is a valid gif? Or that it is actually located there?

  3. ryanfusher
    Member
    Posted 5 years ago #

    No, it is not located there. There is no where that I can find the "comment_new.gif" file. If that is the problem though, why does it show up fine in Firefox? Thanks for your help!!

  4. suprchunk
    Member
    Posted 5 years ago #

    Is it all users who have Firefox? Or just you? If just you then it might be cached from when it was there, or when you were testing.

    Did you ever have that file there?

  5. ryanfusher
    Member
    Posted 5 years ago #

    It is all users who have Firefox. Other users have left comments, but I know they all use Firefox.

  6. suprchunk
    Member
    Posted 5 years ago #

    I will check once I get home and can actually use Firefox.

  7. ryanfusher
    Member
    Posted 5 years ago #

    Suprchunk, thanks for helping me. I am new at this, so your help means a lot!

  8. suprchunk
    Member
    Posted 5 years ago #

    Hey Ryan, just got home and checked. The reason it looks like it is working in Firefox, I believe, is that the alt text is making it look like it is working. IE doesn't handle that as well as ff does I think. If you want it to look the same in IE you might want to put something in the link for the 'title' attribute, or simply make an image, name it the comment_new.gif and place it in the appropriate folder.

  9. suprchunk
    Member
    Posted 5 years ago #

    Just saw that you do have title attribute set. But the comments link is a permalink. So that may be messing it up somehow.

  10. MarkRH
    Member
    Posted 5 years ago #

    I was just looking at the reply form for making a comment and noticed
    the HTML for the submit button is messed up. It's missing a closing "/>".

    This:

    <p><textarea name="comment" id="comment" cols="100%" rows="10" tabindex="4"></textarea></p>
    
    <p><input type="submit" name="submit"  id="comment_submit" tabindex="7" value="Submit Comment" <input type="hidden" name="comment_post_ID" value="158" />
    </p>
    
    </form>

    Should be:

    <p><textarea name="comment" id="comment" cols="100%" rows="10" tabindex="4"></textarea></p>
    
    <p><input type="submit" name="submit"  id="comment_submit" tabindex="7" value="Submit Comment" /><input type="hidden" name="comment_post_ID" value="158" />
    </p>
    
    </form>

    Maybe that's causing IE not to work properly.

  11. ryanfusher
    Member
    Posted 5 years ago #

    Thank you so much! Do you think if I just made the Join The Discussion section a hyperlink instead of a gif file that it would work?

    Mark, great catch. That fixed the problem.

  12. ryanfusher
    Member
    Posted 5 years ago #

    Mark, the code now makes every single person's comment go to the same blog posting. So if I am trying to respond to the newest posting, it will be posted this one older posting...Can you help fix this code issue? It looks like something in that code is making all the postings go to one.

Topic Closed

This topic has been closed to new replies.

About this Topic