WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] IE 6 + 7 not displaying header & sidebar -- Help please. (4 posts)

  1. fotish
    Member
    Posted 7 years ago #

    Hi,
    I am running WP 2.1.3 at the following address lecassecroute.dk and I could really do with some help. I am running my own theme that is based upon the default wordpress theme and I have the following plugins installed:

    Akismet
    Language switcher
    get recent comments
    wp database backup

    but I have ruled them out of the equation.

    The site displays as expected with the following setups:
    Firefox 2.0.3 on OS X 10.4.9
    Safari 2.0.4 on OS X 10.4.9
    Firefox 2 on XP Pro

    However, even though the page validates it doesn't show the header or sidebar in:
    IE6 on XP Pro
    IE7 on XP Pro

    When looking at the source in IE it looks fine, i.e. everything is generated, so I would think it has something to do with the css. But going by PIE I can't recognize any of the normal bugs.

    I will be really grateful for any help offered and I will reply to all posts!

    cheers

  2. fotish
    Member
    Posted 7 years ago #

    Ok, this is a blatant bump but I could really do with some help. Any pointers would be useful.

    I tried it with the IE7 script...that didn't help any and I've scoured the support forums for similar posts.

    ...Does anyone have any good ideas?

  3. fotish
    Member
    Posted 7 years ago #

    Ok...well I worked it out for myself.

    If anybody is interested, it had to do with position:absolute and negative margins. To achieve my layout in Firefox (development browser), I had absolutely positioned various elements and then pulled them around the page using negative margins, which IE didn't seem to like.

    To solve the problem, I conditional commented for IE using position:relative and got rid off negative margins and it dropped into place.

  4. inspecta
    Member
    Posted 6 years ago #

    I am having the same problem. My right sidebar will not display in IE. When I turn add-ons on in IE nothing displays properly.

    I know I'll sound like a newbie, but how do I change the margins?

Topic Closed

This topic has been closed to new replies.

About this Topic