WordPress.org

Ready to get started?Download WordPress

Forums

BuddyMenu BuddyLinks
[resolved] Icons don't show in widget (9 posts)

  1. FlipFl0p
    Member
    Posted 1 year ago #

    Hi Lee,

    Fantastic plugin, thank you!

    I installed and for some reason the icons don't display in the widget. I checked the CSS and originally it had installed to a folder /buddymenu-buddylinks so I renamed to /buddymenu as this is where the CSS is looking but still nothing.

    Additionally did you realise that the Forum link links to Activity? I fixed mine in the PHP but just letting you know.

    Thanks again.

    http://wordpress.org/extend/plugins/buddymenu-buddylinks/

  2. leehodson
    Member
    Plugin Author

    Posted 1 year ago #

    Hi FlipFlop,

    I've released an update to the plugin that fixes the forum link slug. The update should propagate through WordPress over the next 24 hours.

    Someone else mentioned the icons not showing bug. Can you post a link to your site so I can see the source code. Will issue the fix as soon as find the bug. Which browser are you using?

  3. leehodson
    Member
    Plugin Author

    Posted 1 year ago #

    Have released another fix. The icons should now show. I'd changed the plugin directory name during development but forgot to update the CSS accordingly.

  4. FlipFl0p
    Member
    Posted 1 year ago #

    Thanks for the reply Lee!

    Great stuff, as I said I had already fixed the Forum thing but I will update accordingly. I'd rather not post a link to my site on this forum as it's still being finished off but I did also comment on your blog mentioning these issues so if you check your comments you can email me and I'll get back to you there :) name is Ben Dixon.

    I will checkout your fix but as I said I did already check the CSS and rename my installation folder accordingly, however I am not very experienced with PHP/CSS so there may be stuff going on behind the scenes which I also needed to change and didn't.

    Again, thanks for your reply!

  5. leehodson
    Member
    Plugin Author

    Posted 1 year ago #

    Caught your comment on my blog. Have replied there too. You will need to reactivate the plugin after upgrade. I apologize for that but I changed the directory name to prevent confusion with other plugins.

  6. FlipFl0p
    Member
    Posted 1 year ago #

    No need to apologise. Thanks for your response. I've also left you some contact details on the blog. Have reinstalled after the update and checked on my serverto confirm that the folder has gone back to the buddylinks name. Still no icons in any browser, so weird as all the paths seem to be correct.

  7. leehodson
    Member
    Plugin Author

    Posted 1 year ago #

    Emailing you now. Thanks. Do the icons show when you refresh the page with Ctrl+R (it should clear the browser cache for the page)?

  8. FlipFl0p
    Member
    Posted 1 year ago #

    Thanks so much for the support this was a problem with my site. Highly recommended plugin and author.

  9. leehodson
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Ben :)

    You're very welcome for the support. I appreciate learning about the quirks of my plugin as it gets installed on more sites.

    I shouldn't have hard-coded the location of the icons into the plugin's CSS file.

    For others with a similar issue of the icons not showing next to menu items, please check whether your site is installed in a sub directory. If it is, adjust the BuddyMenu CSS file to set the icon URLs to include your site's subdirectory location e.g put the subdirectory name before every instance of /wp-content/.. in the plugin file buddymenu-style.css.

    The file buddymenu-style.css is found in /wp-content/plugins/BuddyMenu-BuddyLinks/

    Will soon release a new version of the plugin that will write the CSS for the icons dynamically. It may be a week before I release it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.