WordPress.org

Ready to get started?Download WordPress

Forums

Basic Google Maps Placemarks
[resolved] Icons are not displayed correctly after update (6 posts)

  1. sideways
    Member
    Posted 4 months ago #

    Ciao Ian, and thanks for the useful plugin. I recently updated to v1.10.1 and something messed with the marker icons: they are displayed large and pixelized.
    You can see what happens here: http://www.firenzekids.it/sale-compleanno
    Any clue?
    Maybe I need to update WordPress?

    http://wordpress.org/plugins/basic-google-maps-placemarks/

  2. Ian Dunn
    Member
    Plugin Author

    Posted 4 months ago #

    If you look at the bgmpData object in the page source, you'll see that the icon URLs look like this:

    http://i0.wp.com/www.firenzekids.it/wp-content/uploads/2013/06/libreria.png?resize=150%2C150

    The ?resize=150%2C150 parameter is requesting a 150x150 px size, which is what it's getting.

    Are you using Jetpack/Photon to host your images? That may be related. When you set the featured image for a marker, make sure you have it set to use the correct size of the original image, and not a resized thumbnail or something.

  3. sideways
    Member
    Posted 4 months ago #

    Yep, I'm using Photon, and I started it the same day I updated BGMP...
    Problem is, in WP 3.5 there is no options when I set the featured image... It's something Photon did on its own. I'll try to work it out from that side...
    Thanks!

  4. sideways
    Member
    Posted 4 months ago #

    Hey Ian, I found this solution: https://ethitter.com/2013/07/disable-jetpacks-photon-module-in-specific-situations/ provided by Jetpack, but honestly I don't know where to paste the two lines of code.
    Any help?
    Thx

  5. Ian Dunn
    Member
    Plugin Author

    Posted 4 months ago #

  6. sideways
    Member
    Posted 4 months ago #

    Ian you are Numero Unoooo!!!
    That definitely worked.
    Yhanks a lot

Reply

You must log in to post.

About this Plugin

About this Topic

Tags