WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] ical not working (19 posts)

  1. jacktowner
    Member
    Posted 11 months ago #

    Hello - using latest versions of events manager and wordpress and am having problems exporting single events to ical format.

    Am using the placeholder #_EVENTICALLINK inside a single event, which seems to just add the /ical/ suffix to the end of the URL. This results in a 404. Tried changing the suffix to 'events.ics' and still got a 404. Google export does work.

    here's a sample event:
    http://www.ncridev.co.uk/events/csg-lymphoma/

    This event is in a particular category with some other events:
    http://www.ncridev.co.uk/events/categories/lymphoma-csg/

    if I tag 'events.ics' onto the end of the category url above, ical export works.

    Have tried disabling all other plugins, still with no luck.

    Any help greatly appreciated.

    Cheers.

    Jack

    http://wordpress.org/plugins/events-manager/

  2. angelo
    NetWebLogic Support
    Posted 11 months ago #

    I tried this link http://www.ncridev.co.uk/events/csg-lymphoma/ and it works fine?

  3. jacktowner
    Member
    Posted 11 months ago #

    Thanks for the reply

    The URL works but the ical feed (next to the Google button) at the bottom of the page doesn't.

    I did a clean install of WordPress and only installed the Events Manager plugin, and the /ical/ suffix seems to work on any single event, so probably not a problem with EM.

  4. DJLunacy
    Member
    Posted 11 months ago #

    Can you get the global list of events in the ical feed?

    Is it just the single events that the feed isn't working?

  5. caimin_nwl
    NetWebLogic Support
    Posted 11 months ago #

    Have you tried re-saving your permalinks?

  6. DJLunacy
    Member
    Posted 11 months ago #

    Yes that didn't work it just brings up ALL events in one ical file In the single event list. Instead of just the event you're presently viewing.

    This is the code i'm using

    Add Event To iCal #_EVENTICALLINK

  7. jacktowner
    Member
    Posted 11 months ago #

    @DJLunacy - yes, I'm using the same link as you
    @caimin_nwl - how do I do that?

  8. angelo
    NetWebLogic Support
    Posted 11 months ago #

    at WP Settings > Permalinks

  9. jacktowner
    Member
    Posted 11 months ago #

    my permalinks are set as Post name

  10. philipjohn
    Member
    Posted 11 months ago #

    Given that your fresh installation worked fine it's likely that a plugin or theme conflict is causing the iCal link to break.

    Try disabling all other plugins and reverting to the default theme to see if the problem disappears, then re-activate plugins to see which causes the link to break.

    Thanks

  11. jacktowner
    Member
    Posted 11 months ago #

    Thanks for the tip PhillipJohn - gave that a try and annoyingly still getting same 404 error.

    I only have a couple of events set up, so I think I'll remove all the events using the dashboard, remove the offending plugin, remove any entries to 'events' in the wp_database. Hopefully that should be enough to clean any residual data, so I can do a 'clean' install, as I've tried reinstalling the plugin, but it remembers the events as they're stored as custom post-types and not removed when the plugin is uninstalled.

    Cheers.

  12. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 11 months ago #

    try the uninstall option whilst EM is activated in your plugins page.

  13. jacktowner
    Member
    Posted 11 months ago #

    Removing the database entries and reinstalling seems to have done the trick - thanks for the advice.

    Each event can be reached through event_url/ical or event_url/event.ics
    All events (including categories) through category_url/events.ics

    Great plugin, BTW. :)

    Cheers

  14. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 11 months ago #

    glad you sorted it out!

  15. DJLunacy
    Member
    Posted 11 months ago #

    What's a recommended fix, if you have many events and you simply can't just remove the event data?

    In my case my theme doesn't have anything to do with the Single event feeds not generating properly. It just does all at once.

  16. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 11 months ago #

    @DJLunacy not sure what you're asking, but I'd raise a new thread on this

  17. DJLunacy
    Member
    Posted 11 months ago #

    I've been having the exact same issue as he describe above.

    Switching the theme doesn't resolve it.

    For a site that's already launched and running with populated events, dumping the db and re-installing isn't ideal.

    Is there a solution that will not result in data loss that would likely resolve the issue of not being able to access ical feeds on a single event basis?

  18. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 11 months ago #

    sorry, didn't realize you posted earlier too :)

    have you tried it with other plugins disabled and maybe even using the default WP theme (saving permalinks after disabling these and then when reenabling too)

  19. jacktowner
    Member
    Posted 11 months ago #

    Not sure if this will help, but I created some custom taxonomies using a seperate plugin which I associated with event manager posts - this may have confused events manager (or WP) and possibly caused the event feed to stop. if you have something similar, to simplify EM functionality it might help to remove any custom taxonomies...?

Reply

You must log in to post.

About this Plugin

About this Topic