WordPress.org

Ready to get started?Download WordPress

Forums

I upgraded, logged in, but then the upgrade.php is blank (14 posts)

  1. robmmad16
    Member
    Posted 5 years ago #

    Hi there,

    I've tried everything, absolutely everything to get wordpress 2.7 to work. So as a drastic step I deleted the entire folder after backing it all up, first the database then the files for wordpress on my server, deleted everything, then uploaded the new 2.7 wordpress, changed the wp-config file to be able to connect to my database. Then my blog shows up in the default wordpress theme, but after logging into the admin panel the page goes blank and doesn't do anything.

    What do I do next? Could it be something to do with permissions of certain files or something, or what is my problem?

  2. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    Please post a URL.

  3. robmmad16
    Member
    Posted 5 years ago #

  4. robmmad16
    Member
    Posted 5 years ago #

    btw, also when I tried to reset my admin password, I receive an email as a confirmation that I want to reset it, there is a yellow field, but below it is a red field with the following text in it:

    Sorry, that key does not appear to be valid.

    I then fill in my emailaddress or username and click to "get new password" but then I get the confirmation email again, not a new password...

    Is that part of the overall weirdness or a problem in itself?

  5. robmmad16
    Member
    Posted 5 years ago #

    could anyone please provide me with some sort of clue or next step to take? I haven't been able to use my blog since JULY! And no solution what so ever! Not even a clean install will work...

  6. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    Your are hosting your own site on your server?

    Since much of your site works I would think it is in your setup (that is why the title does not show) or maybe in your htaccess file.

    Is your wp-admin.php file there? Your wp-login file is not working correctly. Not only does the WP graphic not load completely but in the upper left corner it should say "back to madonnamad.com/blog". It just says, "Back to" - which means something is not configured correctly in your settings.

    Not even a clean install will help

    makes it sound like a server problem but missing key is a password problem . . .

    Try this from Otto42 . . .
    Easiest way to reset your password:

    If you can't login, but you can access your site via FTP, then edit the theme's functions.php file and add this code to it, right at the top after the first <?php bit:
    wp_set_password('password',1);

    Put in your own new password for the main admin user. The "1" is the user ID number in the wp_users table.

    After you then login, make sure to go back and remove that code. Don't leave it there by any means.

  7. robmmad16
    Member
    Posted 5 years ago #

    So, lemme understand this correctly.

    I go into the following folder:

    * blog/wp-content/themes/default

    and I put that code directly under the <?php bit, I replace the "password" between the brackets with my own password, re-upload it and then log in, right?

    Cause I've tried that and it changed NOTHING, blank screen upon log-in!

    :( I'm about to cry!

  8. robmmad16
    Member
    Posted 5 years ago #

    You also asked me for a file called "wp-admin.php"

    Nowhere in the wordpress 2.7 file that I downloaded here is a file called wp-admin.php. Where should it be located? I have a file called admin.php inside the wp-admin folder, if that is what you mean!?!

  9. jdkwebconsulting.com
    Member
    Posted 5 years ago #

    I think it's just admin.php that he should be referring too. I don't believe that there is a wp-admin.phbp.

    admin.php is in the wp-admin folder.

  10. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    The install is not complete or your settings are incorrect. For example, compare http://www.ourexcellentadventures.com/wp-admin/images/browse-happy.gif with your site, http://www.madonnamad.com/blog/wp-admin/images/browse-happy.gif

    Yoursite/wp-admin should take you to the Yoursite/login but in your case errors out with possibly DNS error. Example, http://www.madonnamad.com/blog/wp-admin versus http://www.ourexcellentadventures.com/wp-admin

    Even the theme images are wrong. Although the kubrickheader.jpg is displaying correctly on your blog, it does not when going to it directly, http://www.madonnamad.com/blog/wp-content/themes/default/images/kubrickheader.jpg

    I basically know nothing about servers but since most of the site works, could it be the server settings? Otherwise, I would reinstall the wp-admin and wp-includes folders.

  11. robmmad16
    Member
    Posted 5 years ago #

    I now uploaded everything all over again with fireftp, using the automatic mode, I had set it to ASCII mode previously. I re-uploaded EVERYTHING, all the pics work and load again, but when I log in to my admin panel, still blank pages! I can't get in, at all...

    Another question, is the username you fill in in the wp-config.php file the same as the one you fill in in the log-in screen of your admin panel, cause that username gives me the error message "ERROR: Invalid username", but when I use the word admin in combination with my password it loads but only loads a blank page!

    AAARRRGGGGGHHHH!!!

  12. robmmad16
    Member
    Posted 5 years ago #

    anyone have any solution or updates?

  13. whooami
    Member
    Posted 5 years ago #

    Another question, is the username you fill in in the wp-config.php file the same as the one you fill in in the log-in screen of your admin panel

    no its not.

    but when I log in to my admin panel, still blank pages

    blank pages indicate a fatal php error has occurred. what do your error logs say?

  14. robmmad16
    Member
    Posted 5 years ago #

    then it's not the password that screws up. I have contacted my hosts a few weeks ago but have yet to hear from them, maybe due to the holidays and everything. If I don't hear anything I'll start pulling some strings, because this is getting ridiculous. I can get into my own plesk environment but wouldn't know where to look for error logs...

Topic Closed

This topic has been closed to new replies.

About this Topic