WordPress.org

Ready to get started?Download WordPress

Forums

I really screwed it up (6 posts)

  1. jlswilton
    Member
    Posted 1 year ago #

    Ugh. I was trying to follow the directions from this post about how to fix a problem I was having with seeing drafts after I pushed the site live by moving the index.php file to the root directory.

    I couldn't preview any changes to my drafts, which wasn't going to work for the client. I changed the wordpress address to match the site address, and now I get a 404 error when I try to log in to the admin page. Which means I can't go back in and change it back.

    Does anyone know a way to get back in? I have tried everything I can. And I'm still not sure how to fix my original problem once I get it back.

    Appreciate any suggestions!

  2. jlswilton
    Member
    Posted 1 year ago #

    And my site is all messed up now as well. You can see it here.

  3. loughcorrib
    Member
    Posted 1 year ago #

    Can you ftp to site and move index.php ,Or look at the extension your admin is now in.
    ie. yoursite.com/wp/wp-admin and then try to login by calling that.
    If you manage to login change url in settings.
    You should post your site address, Someone may find the extension that way

  4. In order to get things back the way they were, you'll need to go to your phpMyadmin. Go to the options table and look for site url and home. Change both back to http://nancyzangara.com/wp.

    You'll also want to delete the index.php from the root.

    Once you've done, that, you can then go back and login to your admin.

    When you are ready to go live, you'll want to go to here: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    and follow these instructions.

    I think that you might have forgotten a step.

  5. jlswilton
    Member
    Posted 1 year ago #

    Christine, I will do that and see if I can get it back.

    A question: I did follow those instructions originally. I didn't skip any steps, but I did not have an .htaccess file in my wordpress directory. I could see other .htaccess files in other directories, but not in that one, so I could not do the second part of step 4 in that process. I was following the instructions for 'Using a pre-existing subdirectory install". It is currently in a subdirectory (wp) of my main www folder, so I think that was the correct choice. Do you have any ideas why I don't have a htaccess file? And what I should do about that?

  6. jlswilton
    Member
    Posted 1 year ago #

    Ok, I went in and changed the items in the options table, and that restored my site, even the ability to preview. Not sure why, but I'll take it!

    Thanks so much!

Topic Closed

This topic has been closed to new replies.

About this Topic