WordPress.org

Ready to get started?Download WordPress

Forums

IvyCat AJAX Testimonials
[resolved] I need the title () not to be a link (14 posts)

  1. hansford77
    Member
    Posted 1 year ago #

    At the moment the title of each testimonial is a clickable link that goes nowhere. It isn't even the permalink of the testmionial, which would be bad enough, but a broken link. I can solve this by editing the php of the plugin, but of course this is not a permanent solution as plugin updates overwrite my changes. I don't see a way to unlink it in the widget or shortcode, am I missing something? Thanks.

    http://wordpress.org/extend/plugins/ivycat-ajax-testimonials/

  2. Daniel Gilfoy
    Member
    Plugin Author

    Posted 1 year ago #

    Hello hansford,

    The link should be the correct one. Are you using pretty permalinks? There currently isn't a setting to unlink it, though we can certainly add that feature to the roadmap.

    If you are using permalinks an it isn't working, try rebuilding your permalinks (just go to the dashboard, Settings->Permalinks and just hit save to rebuild.

  3. hansford77
    Member
    Posted 1 year ago #

    Hi, rebuilding permalinks doesn't do anything, but that's only half the point as I don't want it to link at all. I'll just keep editing the plugin every time you update it! Also I'm having to edit the plugin to remove the title "Testimonials", it would be nice to have that option too. Thanks.

  4. suerama
    Member
    Posted 1 year ago #

    How would I edit the plugin to eliminate the broken link issue?
    hansford77, can you please tell me how you did that? What code changes did you make?

  5. hansford77
    Member
    Posted 1 year ago #

    Hi, in ivycat-ajax-testimonials.php, search for the word 'cite'. Between the <cite> tags remove the link, so that you're just left with

    ' . $testimonials[0]['testimonial_title'] . '

  6. Daniel Gilfoy
    Member
    Plugin Author

    Posted 1 year ago #

    Hansford,

    Feel free to make any change you want for your site. You can even fork the plugin if you'd like.

    Are you using the latest version? The "Testimonials" title is not in the lastest version and the overall h3 title is not set by default, you have to manually add it in the shortcode for it to even show up.

    As for the permalinks thing, if you add a new testimonial, or edit an existing and see the permalink and it is something other than ending in a ?p=xx where xx is some number, then the link should work just fine.

    It should be in the format of http://www.yourwebsite.com/testimonials/testimonial-slug/ and that should be the exact same thing that is in the permalink spot when you edit the post in the WP dashboard. If you click view page and get a 404 error and rebuilding permalinks doesn't fix this, you probably have other issues at hand.

    I'v tested it with all of the other permalink structures and only the default setting doesn't work.

    I know you don't want the link and I've said we will add that feature eventually. If you need it in the meantime, feel free to change it.

  7. Daniel Gilfoy
    Member
    Plugin Author

    Posted 1 year ago #

    RE the Testimonials Title:

    It appears that the widget is what you are referring to and the Testimonials title shows up if it is left blank. I'll get that fixed, in the meantime, you could probably just hide it with CSS if it is super urgent. I'll try to get that fix in today.

  8. hansford77
    Member
    Posted 1 year ago #

    Incidentally what I also did was wrap that code in a div tag <div class = "kjh-cite"> and added to the css:
    #ivycat-testimonials .kjh-cite {text-align: right}
    This makes the name shove over to the right, because I think it looks better.

  9. Daniel Gilfoy
    Member
    Plugin Author

    Posted 1 year ago #

    Or, without changing code, can accomplish the same thing using:

    #ivycat-testimonials cite{
        display:block;
        text-align: right;
    }
  10. Daniel Gilfoy
    Member
    Plugin Author

    Posted 1 year ago #

    Odd: When I'm logged in I see my post above the RE the Testimonials Title: post, but don't see it when not logged in. Anyway, here's a screenshot of it:

  11. hansford77
    Member
    Posted 1 year ago #

    Thanks Daniel, I'm a little new at css. I was putting a . before cite when I tried it that way.

  12. hansford77
    Member
    Posted 1 year ago #

    I have now discovered the problem with the links, and it was that I was using default permalinks. Now I'm not, they work. However, I still don't want them! Thanks for all your help.

  13. ivycat
    Member
    Plugin Author

    Posted 1 year ago #

    Pushed new version today with these changes.

  14. hansford77
    Member
    Posted 1 year ago #

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.