WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I need help with my .htaccess (5 posts)

  1. mrscienceteach
    Member
    Posted 4 years ago #

    I have installed 3.0, and then setup Network mode. Two problems:

  2. The .htaccess file blocks access to my login page and my site. If I rename it to disable it, everything works fine.
  3. When I try to create more sites via the Super Admin panel, they look great in the Dashboard, but the sites don't actually get created. The dashboard for the "daughter" site doesn't exist and the site itself isn't there.
  4. Using my school system's web server with my own username and directory. I have played with file permissions, thinking that this is the issue. But, even if I set everything to 777 it doesn't work. Beginning to think that my privileges on the web server are not sufficient. Any ideas?

  • Is the school's web server a Windows box?

  • sarafisk
    Member
    Posted 4 years ago #

    I am having the same trouble as above with a new 3.0 WordPress installation. I followed the instructions at http://codex.wordpress.org/Create_A_Network to do the setup for the Network.

    All works fine within my super Admin as far as setting up blogs, but there are no files and directories set up for those.

    If I upload the .htaccess file with the suggested content from the installation I get a server error when accessing the blog or admin and can go no further, but if the .htaccess file is not there I can see the parent blog and the admin fine.

    I phoned the web-host and they say everything is fine at their end. This installation is on a Linux server at GoDaddy.

    The content of my .htaccess file is as follows....

    RewriteEngine On
    RewriteBase /neighborhood2.0/
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    This of course needs to be working this week. Any help is greatly appreciated! Thanks!

  • All works fine within my super Admin as far as setting up blogs, but there are no files and directories set up for those.

    And there will not be. The blogs themselves are virtual.

    If you're putting in the htaccess file and the site is borking, then your host shoudl be able to help with that. No need to confuse them with multisite. :) Just tell them as soon as you add your custom htaccess file, you get that result.

  • sarafisk
    Member
    Posted 4 years ago #

    Got it solved.

    I use Dreamweaver and it was uploading the .htaccess file in the wrong mode, needs to be ASCII. If I name it htaccess.txt on my local copy and then upload it to the site, then rename it .htaccess there, all is good. (This is easier than using alternate methods of uploading it.)

    Thanks!

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags