WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I need help making a gallery of SWF files (11 posts)

  1. toasticuss
    Member
    Posted 1 year ago #

    Hey everyone, I've been struggling to find any solutions to making a gallery to display individual SWF files.

    I was able to piece together thumbnails with the text editor. Clicking on them will link to the SWF file that will then open on the page using Shadowbox. The problem is they are all scattered and completely un-uniform looking on the page but the code for all of them are the same. Example - http://i.imgur.com/JTx5fEK.png

    Can someone offer some advice on how I can make a gallery of SWF files look good?

    I've looked at picture galleries but they don't support the SWF files.

    Any help would be greatly appreciated!

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You need to look at the CSS for those elements - setting a uniform height will make them the same size and they should then align properly. Try using a browser tool such as Firebug to work with CSS - it's very useful!

    Without a link to an actual page, it's impossible to offer more specific CSS help.

  3. toasticuss
    Member
    Posted 1 year ago #

    Here is a link to the page - http://bearcav.ath.cx/wordpress/flash/ - Note that this site is M rated.

    Ah, so some CSS surgery is needed, I usually jump into Chrome's web tool that is comparable to Firebug. Please let me know if you find anything easy that can be done to fix it. I will work on it and find out what I can =/

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yep, a height is all you need - something like this may work:

    #post-84 .wp-caption {
        height: 40px;
    }

    That applies it to just that page - if you want other pages, modify accordingly.

  5. toasticuss
    Member
    Posted 1 year ago #

    Thank you for that, however it's not quite there, adding that CSS gives it this look - http://i.imgur.com/79DeIP4.png

    Giving it padding just stretches the images and breaks the captions. Any ideas?

    Update: Giving that same CSS tag a margin of 50 gives this - http://i.imgur.com/exCQm5Y.png

    which is much closer!

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    The page you linked to above does not have those "f buttons" visible - I just see the caption text on a white background. Maybe because I don't have flash active? Maybe just try making the height larger?

    EDIT - cross posted - like I said, I don't see the red images at all...

  7. toasticuss
    Member
    Posted 1 year ago #

    Hmm, I think the images paths need to be updated, I originally worked on this from my desktop using local host and migrated it last night, the pictures may still be loading from my computer...

    Anyway I added more height and got a uniform look - http://i.imgur.com/JnB2Xpq.jpg However there is room on the right for them to go but there is a width limiting them, is there anyway to expand it?

    EDIT: Links have been updated from localhost as I suspected to the domain...

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yes, sounds like you have a file path issue. If you need to update the site-wide, this may be helpful:

    http://wordpress.org/extend/plugins/velvet-blues-update-urls/

    Ideally, you should not be making any changes to any theme files - as they will be overwritten when the theme is updated :( . Instead we always recommend to use a Child Theme - http://codex.wordpress.org/Child_Themes

    Or if you are only making CSS changes, you can add custom CSS via a plugin such as Custom CSS Manager or JetPack.

    As to the layout, I'd really need to be able to see a live page - but I'd suggest dealing with the above before you make more changes :).

  9. toasticuss
    Member
    Posted 1 year ago #

    File paths have been taken care of, I also ran the that plugin and it updated 78 other URLs!

  10. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yes, cool. This seems to fix the boxes okay:

    #post-84 .wp-caption {
        height: 140px;
    }

    I'm not sure what else you want to do on that page? Make that section wider? Again, making changes to the theme files is skating on thin ice - but it looks like the width of that section is set inline - so look in the theme options or settings:

    <div id="content" style="width:700px;">

    That theme is not supported here - we don't have access to commercial themes so I'm not sure where you can change that.

  11. toasticuss
    Member
    Posted 1 year ago #

    Ah, I won't bother then. Thank you so much for the help! Marking as resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic