WordPress.org

Ready to get started?Download WordPress

Forums

I moved it. I broke it. (24 posts)

  1. syrupcore
    Member
    Posted 8 years ago #

    crap. I moved a wp site to a new server, followed all the instructions in the codex and after a few attempts, every thing seemed to go fine. Home page comes up, can add posts... But! If you click on any of the posts or the linked pages, you get 'file not found'.

    like, I clicked on the link to the images page and get this:

    Not Found
    The requested URL /images/ was not found on this server.

    What to do? I'm sure this is in here already but I couldn't figure out how to search for it.

    Please help!

  2. vkaryl
    Member
    Posted 8 years ago #

    Did you check to make sure you didn't have hard-coded links which needed to be changed?

  3. syrupcore
    Member
    Posted 8 years ago #

    Thanks vkaryl. I think I'm straight with that. the page links are generated via wp_list_pages and the posts, well, they're posts I just added as tests so I know they're dynamic. They do come up on the front page but as soon you click the heading, you get a Not Found. For instance, I have the home page limiting to one post. then on the sidebar is a get_posts to list recent posts. Clicking one of those also leads to a Not Found.

    I feel like I've missed a directory structure setting somewhere but I checked through all the options in the admin panel and set everything that seemed relevant. Could it be something on the new server itself I need to set?

    ugh.

  4. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Redone permalinks ?

  5. vkaryl
    Member
    Posted 8 years ago #

    Beat me podz!

    Didn't get a "permission denied" error, but double-check your permissions anyway....

  6. syrupcore
    Member
    Posted 8 years ago #

    Thanks podz. I'm not sure what I need to redo. I checked it in the admin panel. I'm using /%year%/%monthnum%/%day%/%postname%/ and in the examples it shows, the url is correct. Is there something else to change somewhere?

  7. syrupcore
    Member
    Posted 8 years ago #

    I was just reading http://codex.wordpress.org/Using_Permalinks#Editing_Rewrite_Rules_.28.htaccess.29 at the codex. Should I try deleting my .htaccess file?

    I'm using 1.5 so appearantly wp will just generate a new one for me.

    maybe? please pardon my handholdingish request.

  8. Mark (podz)
    Support Maven
    Posted 8 years ago #

    don't delete it - rename it to htaccess.txt just in case you need it back

  9. syrupcore
    Member
    Posted 8 years ago #

    thanks again but it didn't work.

    When I click a link and get:
    Not Found
    The requested URL /2005/08/19/saturday-20th-august/ was not found on this server.

    should the entire url(http...) be in there?

    fark, I dunno. sad.

  10. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Yes - link to your site ?

  11. syrupcore
    Member
    Posted 8 years ago #

  12. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Your permalink structure - is it just %post% ?

    If so, make it longer ? Copy the default.

  13. syrupcore
    Member
    Posted 8 years ago #

    thanks podz. I'm using:
    /%year%/%monthnum%/%day%/%postname%/

  14. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Has this server got mod_rewrite ?
    Wierd ....

  15. syrupcore
    Member
    Posted 8 years ago #

    I just browsed my db via phpmyadmin and under wp_posts the GUID is coming up as http://www.purelymancity.com/?page_id=2

    the '2' is obviously just from the page I copied. a different page is coming up as http://www.purelymancity.com/images/historical/ that's for the 'historical' page, created as a child page of the 'images' page.

    I dunno if that info is useful at all but it I thought I'd put it up here in case that offers some clue.

    if seeing it actually working will help, here's the testing server URL I built it on:
    http://purelyfootball.moonbootdesign.com

    thanks.

  16. Mark (podz)
    Support Maven
    Posted 8 years ago #

    It's got to be rewrite rules.....
    try this:

    Permalinks - empty the structure box, click Update
    Delete the .htaccess
    Open Notepad, press space once, save as htaccess.txt
    Upload
    Change it's name to .htaccess
    CHMOD (change file permissions) it to 666
    Go back to structure and put back in what you had, click Update
    Go to blog
    Press ctrl+f5
    then click a post title.

    Do this carefully - don't skip any part - and let us know what happens

  17. syrupcore
    Member
    Posted 8 years ago #

    podz. thanks. so much. I think I have mod_rewrite problems. I googled around for a way to test it. I made a .htaccess file with this in it:

    RewriteEngine On
    RewriteRule ^test1.html$ /test2.html [R=301]

    I then made the two html files. When I pointed my browser to test1.html I saw the content of test1.html when, I think, I should have seen test2.html. no?

    With that said, should I even try the steps you laid out? Do I need to tell the guy I built it for that he picked a bad server? abandon permalinks?

  18. syrupcore
    Member
    Posted 8 years ago #

    I went ahead and tried your instructions anyway. It didn't work. I presume, without knowing much, that the server doesn't support mod_rewrite and that's the problem. When I delete the structure entirely, the site works again, it just has ugly urls. I guess this will do for now.

    last question: If I convince him to switch to a server that supports mod_rewrite and I move the database again (poo!) and re-instate permalinks, will it all work?

    Podz, thank you so much for your help. I really really appreciate it.

    Will

  19. vkaryl
    Member
    Posted 8 years ago #

    Have you tried asking the host to enable mod_rewrite? That would be preferable to moving again. Some hosts with whom I'm familiar will enable it on a per-user basis....

  20. syrupcore
    Member
    Posted 8 years ago #

    yeah, I just sent them a support request - my fingers are crossed. Thanks a lot for your help vkaryl.

  21. vkaryl
    Member
    Posted 8 years ago #

    Well, very best of luck with it. I know this kind of thing can really ruin a webdev's day! Let us know how it goes....

  22. angsuman
    Member
    Posted 8 years ago #

    Try wordpress tip on permalink option.

    It doesn't require mod_rewrite to function. It will solve your problem.

    let me know how it goes.

  23. syrupcore
    Member
    Posted 8 years ago #

    angus, took me a while to try it but I just did and it works well. every uri has index.php in it but that's better than pageid=9 or whatever. thanks a lot.

    Will

  24. angsuman
    Member
    Posted 8 years ago #

    @ syrupcore
    I am glad to know it worked for you.

    BTW: I am Angsuman not Angus :)
    Just protecting the copyright on my name LOL

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.