WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I miss "Grant this user super admin privileges for the Network" checkbox. (10 posts)

  1. pescadito01
    Member
    Posted 2 years ago #

    Hi, i have a WP 3.3.2 Multisite site, but before update it i want to have a second superadmin user.

    So, i created a new admnistrator user in the main site, next i changed to network admin and edited that user to check the "Grant this user super admin privileges for the Network" box but the checkbox is losed.
    Have anybody a tip to restore it?

    Before of that when i had not acces to Network Admin Menu i get to restore it by editing the superadmins row of wp_sitemeta database (thanks Ipstenu)

    Best Regards, Pescadito

  2. Checkbox is losed? You mean it's missing? What page are you on?

  3. pescadito01
    Member
    Posted 2 years ago #

    From Network Admin Users, when i edit some first site administrator use, all the edit user page is there, like always, except it doesn't show the CheckBox and the associated message "Grant this user super admin privileges for the Network". That is: the checkbox and the message is missing in the edit user page.

    Or perhaps i first can verify if the used ..\wp-admin\user-edit.php had been changed or it is equal to the original WP3.3.2 user-edit.php

    So, any idea??

    Best Regards, Pescadito

  4. pescadito01
    Member
    Posted 2 years ago #

    ok, i check to find some diff in ..\wp-admin\user-edit.php with the original WP3.3.2 file, but nothing was found?

    have anybody some idea of why this 'grant' checkbox was missing?

    Best Regards, Pescadito

  5. Upgrade to 3.4.1 first of all. It's there on my installs.

  6. pescadito01
    Member
    Posted 2 years ago #

    Ok, i update to WP3.4.1 but without successful!
    See the missed ckeckbox:
    http://postimage.org/image/s5kq2k0zp/ users in first site
    http://postimage.org/image/jol7rmwat/ user-edit page in network admin
    ...?

  7. Start with turning off all your plugins.

    Also consider this: You have at least 17 things needing updating on your site. Part of why we urge you to keep updated is that it can prevent things like this from happening.

  8. pescadito01
    Member
    Posted 2 years ago #

    i do this:
    1) from network admin, users i edit the user i want to grant superadmin
    2) from filezilla, i rename wp-content folders plugin as plugin1 and mu-plugins as mu-plugins1 (to deactivate all plugins)
    3) then i reload the edit-user page of step 1

    but nothing happened, the checkbos still is missed.

    any idea?

  9. The other obvious option is your main site's theme is doing this. But again, I can't reproduce it anywhere.

  10. pescadito01
    Member
    Posted 2 years ago #

    Eureka Ipstenu!!

    Forget the plugins, it was the theme.
    It worked well when i change the theme to twenty eleven
    I suspect of some sort of virus responsability.

    Best Regars, Pescadito

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.