WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I lost posts while updating WordPress (12 posts)

  1. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    I updated WordPress 3 days ago. After updating I got blank pages, and could not even log in. Then I reinstalled WordPress from CP of my hosting company. The result was I got a new blog with none of my previous posts. Two new databases were created one of which is in the wp-config.php file. My backed up database files are in the FTP panel, but not in the database list. My uploads (images) are also in the FTP panel. I placed the problems before customer support of my hosting company. I got no specific replies, but only some stock replies. Will anyone help me by advising me what to do?

  2. hockeyhero4
    Member
    Posted 2 years ago #

    Your description is a bit confusing but let me try my simple approach before getting into this deeper.

    Open your wp-config.php file in the root directory of your FTP.

    Then I would see what database is being called - if it's the new one, switch it to the old one.

    Basically what I'm saying is to look at this section:

    // ** MySQL settings - You can get this info from your web host ** //

    /** The name of the database for WordPress */
    define('DB_NAME', 'YOUR DB NAME HERE');

    /** MySQL database username */
    define('DB_USER', 'YOUR USER HERE');

    /** MySQL database password */
    define('DB_PASSWORD', 'YOUR PASSWORD HERE');

    /** MySQL hostname */
    define('DB_HOST', 'YOUR HOST HERE');

    and ensure everything is the way it should be to coincide with your old settings.

  3. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    I have tried it when I got the message telling "Error establishing a database connection".
    Now, excepting the newly loaded WP, there is nothing in the old WP files. My mySql back up files and uploads are saved and already in the directory. But the database page shows only the newly created DBs. And that is what you can see in my site now.

    So, I think I have to link the old DB backups to the new installation. Don't know how, excepting vague ideas.

  4. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    And the stored error logs are not EDITABLE (can't even read/ cant open).

  5. hockeyhero4
    Member
    Posted 2 years ago #

    Ack - I'm sorry but I'm not sure what I'd do in this situation. Hopefully someone else can come in and share an idea because I've never experienced this before.

    Future note - definitely get a backup plugin like BackupBuddy or something just in case this happens again. I'd also suggest setting up a DEV Site (test site) to do all updates on before going hot on your live site.

    Best of luck.

  6. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    @hockeyhero4, Thanks a lot for the advice. The problem is persisting, more or less, from what I understand from other similar posts in this forum, I think, I may have to change hosting. I had similar problems with some other blogs hosted elsewhere before. But I could solve them with the help of the customer support.

    Thanks again.

  7. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Sorry, I did not report here that the issue was resolved. The problem was in the corrupt database files which I repaired. I set it alright and the site is back to normal.

  8. mpromp2
    Member
    Posted 2 years ago #

    I am having the same problem..... I completed the WordPress update. Now I have lost 2 days of post and I can't log into wordpress not. PLEASE HELP

  9. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    @mpromp2,
    Wait. I am busy elsewhere. I will look into it after a few minutes.

  10. janiceandcompany
    Member
    Posted 2 years ago #

    This is so damn annoying, it has happened to me on 3 sites.

  11. info@exploreafrica.net
    Member
    Posted 1 year ago #

    I have lost all 2011 and 2012 posts after upgrades. Went to Twenty Eleven theme, changed permalinks to default, tried use google library plugin, so not sure why my most recent posts are missing.

    Example of my most recent post that is gone: http://www.exploreafrica.net/blog/2012/06/

    Get internal server error!

    Please help.
    Cathryn

  12. keesiemeijer
    moderator
    Posted 1 year ago #

    @janiceandcompany, @info@exploreafrica.net, @mpromp2
    Please create your own topic as this one is resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic