WordPress.org

Ready to get started?Download WordPress

Forums

I lost my hope :( Getting apache, MySQL, PHP working on Windows 7 (25 posts)

  1. squirrel-lt
    Member
    Posted 4 years ago #

    This is the fourth day I'm trying to get wordpress work on windows. When I upload to Linux server everything works just fine, but I want to make a theme for blog, so the best way to do it is to have wordpress running on PC. The problem is, that install.php index.php any file loads loads and then... nothing... blank page. I've tried everything, I read all topics regarding this problem, as well as other websites via google, but problem still exists. Latest Apache, latest MySql, latest PHP, latest wordpress, everything is configured just fine. I am using Windows 7 if that has anything to do with this problem.

  2. rodries2
    Member
    Posted 4 years ago #

    probably you have display errors disabled in php.ini try to enable it to see the error

  3. MichaelH
    Member
    Posted 4 years ago #

    Typically, a blank screen after an install may mean you didn't get a complete and intact set of WordPress files uploaded to your host. I'd consider downloading a fresh copy of WordPress from the Download tab at the top of this page, then use something like 7-Zip to extract the files. Then reupload the files to your host. Review Uploading WordPress to a remote host and make sure you are using ASCII transfer mode in your FTP client.

    If you have an .htaccess file, that too could be causing the problem--rename that if necessary.

  4. squirrel-lt
    Member
    Posted 4 years ago #

    I feel like you didn't read my post. Everything works fine when uploaded to host, it just doesn't work when I try to INSTALL wp on MY PC. Install.php returns in blank page, as well as other files, so I can't even install it.

    rodries2 i have it enabled:
    display_errors = On
    still blank page

    log_errors = On
    no errors in log

  5. pipegm
    Member
    Posted 4 years ago #

    Same problem as aquirrel-it

    I'm about to abort using wordpress.

    I've had 3 days in a row wasted on this thing.

    Done the wp-config 4 times, (I am almost sure everything is ok) uploaded a million times and still when I try opening http://www.XXXXXX/wordpress/wp-admin/install.php

    this is all I see:

    Warning: require_once(C:\Hosting\5276971\html\wordpress/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in D:\Hosting\5276971\html\wordpress\wp-admin\install.php on line 18

    Fatal error: require_once() [function.require]: Failed opening required 'C:\Hosting\5276971\html\wordpress/wp-load.php' (include_path='.;C:\php5\pear') in D:\Hosting\5276971\html\wordpress\wp-admin\install.php on line 18

  6. squirrel-lt
    Member
    Posted 4 years ago #

    At least you get error message :\

  7. rodries2
    Member
    Posted 4 years ago #

    pipegm: I had the same error but I don't remember how I fixed it :(
    try to delete wp-config.php and retry install.php

    which php version are you using? (unix or windows ? )

    squirrel-lt:
    try to reinstall deleting wp-config.php also you can add this 2 lines in install.php to be sure that errors are showed
    <?php
    error_reporting(E_ALL | E_STRICT);
    ini_set("display_errors", 1);
    ......
    ......

    it's strange a blank page

  8. squirrel-lt
    Member
    Posted 4 years ago #

    After I click SUBMIT it returns in error in Opera, but because error is in Lithuanian language I can only copy what Mr. Explorer said:
    Internet Explorer cannot display the webpage
    That's it! Isn't really helping, is it?

    I noticed that it didn't create wp-config.php file from sample, so perhaps this has something to do with writing permissions? I am using Windows 7 so who knows.

  9. rodries2
    Member
    Posted 4 years ago #

    squirrel-lt I think that you are rigth, maybe is a permissions problem.
    You can try to investigate the user Apache service is using, then give writing permissions to that user in your wp directory, but I'm not sure
    I'm not using windows 7

  10. squirrel-lt
    Member
    Posted 4 years ago #

    Okay I'm sick of this, I imported sql db from linux server to my pc, copied all files from linux server to pc, and blog still doesnt work, same problem - BLANK PAGE. I am really mad, I've been trying to get this **** work for week, gaaaarrgghhh!!!

  11. design_dolphin
    Member
    Posted 4 years ago #

    Will any other websites/ webpages/ cms's work on your Xampp installation?

    Setting up Xampp on a Windows box can sometimes need a bit nudging to get going.

    A.F.A.I.K. WordPress should run fine on Xampp on Windows XP and Vista. I don't know about Windows 7 though. Maybe somebody else can help you there.

  12. squirrel-lt
    Member
    Posted 4 years ago #

    Okay I have just tried to install phpbb3 and after filling all db info and clicking proceed same thing happens. I have no idea why. It says that folders and files are writable, connection with sql is ok, php works fine... It just doesn't crate any table in database, so this could be a problem I think. Now... how to solve it?

  13. squirrel-lt
    Member
    Posted 4 years ago #

    I've tried everything, googled for so many hours and I still can't get any script installed, every time I click NEXT button (any script) after filling database info, nothing happens, browser simply prints an error without any info. I really don't know what to do. I never had such problems until upgraded to Windows 7.

  14. MichaelH
    Member
    Posted 4 years ago #

  15. squirrel-lt
    Member
    Posted 4 years ago #

    Moderate title again then, because I don't use XAMPP (I never said that!) I downloaded all three components and configured it myself. It always worked on XP. I'm sorry if I look too umm... harsh? But I feel like you either don't understand what I'm saying or don't read, because, as I said, everything works fine until I click the button to add tables to MySql database (after filling db info clicking SUBMIT). So links you provided aren't really helpful because I have no problems starting apache + php + mysql and all three components working. I'm sorry again if I look a little rude, I didn't mean to, that's because English isn't my main language :)

  16. ClaytonJames
    Member
    Posted 4 years ago #

    Clearly, squirrel-it, since you have duplicated the symptoms using more than one application, you need to isolate your efforts to:

    A) At what point you botched the ability of MySQL and PHP to communicate with each other when you installed the applications on Windows, or

    B) What windows component is not allowing your PHP to communicate with
    MySQL when you attempt to run a script.

    MichaelH has pointed you towards sources of information relative to both, whether you like the word "XAMPP" in the title or not.

    Frankly, I'm betting you missed a least one of a couple of crucial, but subtle steps that are required to make the applications work together properly on Windows.

    I downloaded all three components and configured it myself.

    That does not mean you properly configured them, or paid attention to the warnings about using an .msi package to install PHP on windows.

    I have read your posts, and it is more about the things you have not said, than what you have, that makes me believe you have missed important steps while installing PHP, MySQL, and Apache on Windows.

    XAMPP might actually be the fastest, easiest solution to your problem.

  17. design_dolphin
    Member
    Posted 4 years ago #

    @ClaytonJames,
    I agree.

    However it is still my bad for misinterpreting the post in the first place.

    @squirrel-lt

    I got the idea that you were using Xampp after your reply to my post.

    MichealH is of no blame here.

    My apologies.

    You will have to go through the documentation on the web to see if anyone else is setting up Apache, Mysql and PHP from scratch on Windows 7. And see if there any errors on Windows 7. Maybe Windows Vista documentation can also be of some help. But I am not sure about this.

    A Windows 7, Apache, Mysql and PHP forum might be a better place to start. I don't know many people that run from scratch on Windows for building websites, mainly because Xampp is available, and this does all the difficult setting up part automatically, usually. There have been cases of problems before when a new Windows version is released. After awhile this is usually sorted.

  18. MichaelH
    Member
    Posted 4 years ago #

    Okay I have just tried to install phpbb3 and after filling all db info and clicking proceed same thing happens

    Based on that, it would seem the advice from design_dolphin and ClaytonJames to approach another forum specializing in Apache, Mysql and PHP, is appropriate.

    [Title moderated again]

  19. alexl9
    Member
    Posted 4 years ago #

    then this is the website for you ;)

    he has a whole section about running WP on windows.

    http://www.iisadmin.co.uk/

  20. doogle
    Member
    Posted 4 years ago #

    I'm seeing the same behavior with Apache2.2 / MySQL / PHP / WordPress. It appears PHP has been installed correctly. Oddly php.ini needs to be in C:/windows, which is different type set-up from all previous windows OS set-ups (pre Windows 7). I get a plain blank white screen of death on step-2 of the install.php file.

    Measures taken
    -Installed Apache 2.2
    -Installed PHP 5.3.1 MSVC6 (non-msi)
    -Installed MySQL (localhost creating user password and dummy table)

    Other notes: phpinfo.php works and shows extensions and mysql allows me to create a table via command line. It just seems the wordpress installer does not fly. Not sure... Sorry I did not mess with the php.ini error settings and have not looked at the error.log in apache.

    -Best,
    Doug

  21. Grindlay
    Member
    Posted 4 years ago #

    Hmmm... next step would be to look in the apache log and see if it says the page loaded OK. Suspect it will as it's a blank page but you never know for sure until you look.

  22. bohica61
    Member
    Posted 4 years ago #

    If you're using WordPress locally with Windows 7/Apache/MySQL and getting a blank hanging screen on install, the problem may be due to using "localhost" as the host name.

    I had the same problem -- very frustrating, because there's no feedback at all for a problem, no error messages, logs not showing anything unusual, no way to figure out what's going on.

    So I put my programmer hat on, wrote some test PHP code and did some digging. Apparently there's a bug in Windows 7 that causes MySQL connection requests to time out when using "localhost" as a host name. (details here -- also affects Vista.)

    So here's how I finally got the install to work:

    • Edit the file C:\Windows\System32\drivers\etc\hosts. Note: You will need to run your editor with admin privileges.
    • Select a new host name (e.g. "myserver") and add a new line to your hosts file:
      127.0.0.1 myserver
    • In your wp-config.php file (or when prompted running install.php with the sample config) use "myserver" as your host name.
    • After installing, access your blog using http://myserver/

    There's another benefit to using a custom server name in the hosts file: if you, like me, want to work on multiple websites locally, you can use Apache's named virtual host capability by adding a new name to the Windows hosts file and using the VirtualHost directive in the Apache httpd.conf file. Now you can have a second test blog on your local machine (e.g. http://angrycustomer/). Repeat as necessary.

    To anyone reading this: Please reply if this fixes your problem. I'd like to know my effort helped someone else out there. WordPress is too good to let isolated problems like this stop you from using it.

  23. EagleWorks
    Member
    Posted 4 years ago #

    Hello Everyone,

    I am having exactly the same issue as the OP.

    I have tried every fix, including the one above by bohica61.

    I have installed the latest WAMP onto Winows 7, Apache is running, MYSQL is fine, allowing database creation, and phpmyadmin works perfectly. However I still get the blank page after hitting install for WordPress.

    This is beginning to really annoy me, been attempting to fix this all day nearly. I just can not fathom why it will not work.

  24. sdwood
    Member
    Posted 4 years ago #

    Hello - i too have been having this very problem. Sadly I do not yet have a fix for it either. It worked fine in XP, just wont work in Windows 7.

    > Based on that, it would seem the advice from design_dolphin and
    > ClaytonJames to approach another forum specializing in Apache, Mysql
    > and PHP, is appropriate.

    These are all installed and working together perfectly well, the same Apache instance I want wordpress on is serving a PHP application that is using a MySQL database (on server "localhost" btw). Nothing to do with the installation of these three things I suspect the other posters are the same. The WP user is set up and has all privileges - i can't work this one out either...

  25. sdwood
    Member
    Posted 4 years ago #

    Ah...

    yes - checking my PHP application that was working I notice the database connection code uses 127.0.0.1 instead of localhost.

    So bohica61 was pretty much right it seems with :
    >Apparently there's a bug in Windows 7 that causes MySQL connection >requests to time out when using "localhost" as a host name. (details >here -- also affects Vista.)

    My fix was to change "localhost" to "127.0.0.1" when asked for the database host in wp-config. What a pain in the ass ! Let me know if this fixed it for you as well.

Topic Closed

This topic has been closed to new replies.

About this Topic