WordPress.org

Ready to get started?Download WordPress

Forums

Image Source Control
[resolved] I get a fatal error on installation (9 posts)

  1. eeb1
    Member
    Posted 7 months ago #

    Hello,

    I would like to use your plugin however on activation I get this error:

    Plugin could not be activated because it triggered a fatal error.

    Please advised.

    Thank you
    eeb

    http://wordpress.org/plugins/image-source-control-isc/

  2. Thomas Maier
    Member
    Plugin Author

    Posted 7 months ago #

    Hi eeb,
    I just took a clean WP 3.8.1 and installed the plugin successfully. So at least there doesn’t seem to be a general problem. Is there any error message given?

    Maybe this article can help to find one: http://premium.wpmudev.org/blog/troubleshooting-wordpress-common-fatal-error-messages-and-how-to-fix-them/

    Thanks
    Thomas

  3. Thomas Maier
    Member
    Plugin Author

    Posted 5 months ago #

    might be related to http://wordpress.org/support/topic/fatal-error-1106

    should be fixed in v 1.4.2

  4. AndrehF
    Member
    Posted 4 months ago #

    I just tried to install on a 3.8.1, same 'fatal error' with no further information... i will investigate

  5. Beer
    Member
    Posted 3 months ago #

    How many posts do you have? We're getting an out of memory error on activation.

    It's probably due to the init_image_posts_metafield() method pulling all posts of any type at once instead of in smaller memory efficient batches. At least, that's likely the cause of the issue on our install.

  6. Thomas Maier
    Member
    Plugin Author

    Posted 3 months ago #

    @Beer, how many posts (all post types) and images are we talking about? Any specifics about your blog, e.g. 1.000.000 auto generated posts, or so? I did use the plugin on very large blogs already, but never met this problem – not saying that it doesn’t exist though.

  7. Beer
    Member
    Posted 3 months ago #

    There were about 30,000 posts and no images with that test. I pinpointed the error to out of memory with that method. It makes sense if you look at the query. It's just requesting all posts.

  8. Thomas Maier
    Member
    Plugin Author

    Posted 3 months ago #

    Thanks, Beer.
    Please outcomment the following line 1111 in isc.class.php

    $this->init_image_posts_metafield();

    and try activation again. Does the list with the missing image sources in the dashboard list your images than?

    If so, I might just (re)move the function from activation.

  9. Thomas Maier
    Member
    Plugin Author

    Posted 1 month ago #

    this should be fixed with verison 1.6

Reply

You must log in to post.

About this Plugin

About this Topic

Tags