WordPress.org

Ready to get started?Download WordPress

Forums

I get a 404 error when I try to login to my wordpress admin site (16 posts)

  1. raphaelbender
    Member
    Posted 1 year ago #

    Hi there,
    I get a 404 error when I try to login to http://www,breathe.edu.au/wp-login.php

    The front end site is working - I juat can't access the admin area.

    I've logged in to my web hosting service via FTP and the wp-login.php file is there in the root directory.

    Can you offer any advice please?
    Many thanks,
    Raphael

  2. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Are you running any plugins? If so, using ftp change the name of the plugin directory to plugins-old and try to log in.

  3. raphaelbender
    Member
    Posted 1 year ago #

    Thanks, I just changed /wp-admin/plugins.php to plugins-old.php but no joy.

  4. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Rename OptimizePress to OptimizePress-old. We want to have wp load the default theme to rule out theme problems.

  5. raphaelbender
    Member
    Posted 1 year ago #

    Ok did that:
    Changed wp-admin/wp-content/Optimizepress to /Optimizepress-old

    Still can't login.

  6. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    From your theme's support FAQ,

    If you are having problems accessing the members area, please read below.
    Your access details will have been originally sent to you in an email with “your OptimizePress access details” in the subject line. Please search for this email in your email client to find your original access details.
    If your username/password are not being accepted, please try using your email address for your username, as this may work instead of your username like “JamesDyson”
    If you still can’t get your password to work, you can reset your password by
    clicking here
    . Please note this will take you to a form where you will enter your username or email and will be sent an email. In this email, you will need to click a link to then setup a new password.
    If you are still having problems getting access after checking all of the above, please contact our
    helpdesk

  7. raphaelbender
    Member
    Posted 1 year ago #

    I'm not clear what you mean by that - I'm not having trouble logging in to the OptimizePress site, but the admin area of my wordpress site.

    BTW when I changed OptimizePress to OptimizePress-old, the front end site didn't load, so I've changed it back. The front end site is now up again.

  8. Gadgetroid
    Member
    Posted 1 year ago #

    Check your .htaccess file.

  9. raphaelbender
    Member
    Posted 1 year ago #

    Thanks I did check .htaccess: Here are it's contents:

    # BEGIN s2Member GZIP exclusions
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} (^|\?|&)s2member_file_download\=.+ [OR]
    RewriteCond %{QUERY_STRING} (^|\?|&)no-gzip\=1
    RewriteRule .* - [E=no-gzip:1]
    </IfModule>
    # END s2Member GZIP exclusions

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  10. marksjo
    Member
    Posted 1 year ago #

    I'm having the same issue. I logged into the Admin section of my website last Thursday with no problems, but when I go to use it today it gives me the 404 error "The requested URL /wp-login.php was not found on this server." All I did last week was upload some photos, I didn't change any code or do any updates. The front end of the site looks fine. Any help would be greatly appreciated. My site is http://acenights.com.au/

  11. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Raphael,
    It's worth a try to reset your permalinks to default (temporarily) and then see if the error goes away. You can revert to your preset settings after trying the default settings.

    @marksjo, please start your own topic.
    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

  12. raphaelbender
    Member
    Posted 1 year ago #

    Thanks Krishna,

    How do I reset the permalinks without logging in? Can I do that manually via ftp?

  13. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Go to phpMyAdmin, look for wp-options table and scroll down until you see the option name permalink_structure. There you will find option vale that can be changed and saved. You need not essentially change to default but you can change, say to /%postname%.html. You can change to current settings afterwards.

  14. raphaelbender
    Member
    Posted 1 year ago #

    Krishna hi,
    I've had our web guy have a look at the site and he's found a neat workarout I thought you may find useful for future occurences of the same issue. Here's what he had to say:

    Hi Raphael,

    As a complete "dodgy-brothers" bandaid while I sort this out, I have duplicated the wp-login.php file and called it login.php and changed all references within login.php to point to itself, so if you go to:

    http://www.breathe.edu.au/login.php

    You should be able to login via this end point and get some work done while I sort this out - I tested it out and seems I can login and logout. Funny thing is, the "logout" calls the original wp-login.php file and it is fine!

  15. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Sorry, we do not advise editing/modifying WordPress core files.

  16. janstevens1
    Member
    Posted 2 months ago #

    I get the error message 404 when I type in the search bar /wp-login. This has not happened before. I cannot get into the dashboard to update changes.

Topic Closed

This topic has been closed to new replies.

About this Topic