WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I Don't Want Coments! (6 posts)

  1. hbixler03
    Member
    Posted 7 years ago #

    I have changed the setting on my blog to NOT accept comments and that no one can post a comment unless they have a previously approved comments, I thought this would be enough to stop the spam, but no I woke up this morning to find 44 new spam messages even after I JUST deleted 400 spam messages from the comment section of my blog!

    I want to turn off the ability to post comments on my blog, please advise how to do this.

  2. deltaomicronmu
    Member
    Posted 7 years ago #

    Look into the plugin named "Spam Karma 2" - it works very well

  3. Chris_K
    Member
    Posted 7 years ago #

    Those are very likely Trackback spam, which is subtly different from comments.

    Standard reply follows:

    Install and activate Akismet or Spam Karma 2. Then install and activate Bad Behavior.

    http://akismet.com/
    http://unknowngenius.com/blog/wordpress/spam-karma/
    http://homelandstupidity.us/software/bad-behavior/

    For those who struggle with the Akismet directions: http://wordpress.com/api-keys/

    See also the Combating_Comment_Spam page in the Codex.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    If you don't want any pingbacks or trackbacks, then turn off "Allow link notifications from other Weblogs (pingbacks and trackbacks.)" on the Options->Discussion page. Also edit every post and turn off "Allow Pings" as well as "Allow Comments".

    These options should not be used to stop spam though. The only way to stop spams is spam blocking plugins. Bad Behavior. Akismet. These solutions *work*. Disabling comments and such is just hurting your blog.

  5. geoffe
    Member
    Posted 7 years ago #

    And if you want to quash trackback spam and don't want to go into every post to turn off Allow Pings, you should use this query in phpmyadmin to disable all trackbacks and pingbacks:
    Update wp2_posts set ping_status="closed"

    where wp2 is the prefix you would be using for your WordPress tables.

    This will disable trackbacks on all posts. I had the same trouble as you, did this and problem solved.

  6. hbixler03
    Member
    Posted 7 years ago #

    Thanks for your help everyone! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags