WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I don't see "comment" section in my "pages" (5 posts)

  1. meistudio
    Member
    Posted 1 year ago #

    Hi,
    I have comment section in post areas, but in "page" area, at the bottom part it is empty, no comment section.
    I actually import all blog posts and pages from my wp.com blog. I do have one comment on one of my pages, but I cannot view in my wp.org blog.
    Thanks for any help.
    Mei (studio)

  2. paulmalenke
    Member
    Posted 1 year ago #

    When you are looking at the list of all of your pages in the dashboard there is the option to Edit or Quick Edit the page when you hover over it. If you select Quick Edit there should be a checkbox there to allow comments on the page or not.

    Let me know if this helps.

  3. meistudio
    Member
    Posted 1 year ago #

    Thanks paulmakenke.
    I saw that earlier and it was checked (allowed) to all my pages. It still don't show. I somehow suspect this is due to the special theme I am using "Almost Spring Adsense". I tried to edit code, but it didn't work out.

  4. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    if page.php does not have it already, add a line like this somehwere after the line with the_content():

    <?php comments_template(); ?>

    http://codex.wordpress.org/Function_Reference/comments_template

    possibly compare single.php with page.php to find out where the line should go.

  5. meistudio
    Member
    Posted 1 year ago #

    @alchymyth, i just did and it worked!
    earlier i tried to copy similar codes from "single post" php code, didn't work out. but yours worked right away.
    thanks a lot!

Topic Closed

This topic has been closed to new replies.

About this Topic