WordPress.org

Ready to get started?Download WordPress

Forums

I don't have permission to preview posts (38 posts)

  1. erinmidwife
    Member
    Posted 5 months ago #

    I have a plugin keeping my site on maintenance mode while I change themes. I am trying to transfer the old site and make all the tweaks with the new theme, and continue to receive the error message when I click on preview post that I do not have permission to preview. I am the only admin/user for my site. I received this error message prior to installing and switching themes but lived with it.

    Thanks for any help.

  2. erinmidwife
    Member
    Posted 5 months ago #

    I was previously initially able to login to my dashboard and unable to login to subsequent requests for my username/password. I poked around and deleted one of my users (which was also me) and am now unable to login anywhere as admin. The password field contains a stored password. Deleting and entering in my current password does not work. I already deleted cache and cookies and enabled cookies.

    All I wanted to do was change my theme in the few hours I had after my kids went to bed. Now I can't even access my site. :(

  3. erinmidwife
    Member
    Posted 5 months ago #

    Somehow I was able to login with the same password on one attempt, get into my dashboard, and make some changes. Then, I was asked at another point to re-enter the info again at which time it was not accepted. So, here I am, unable to login again. I suspect it is some funky setting or cookie or something...?

  4. erinmidwife
    Member
    Posted 5 months ago #

    Still not able to login with every attempt. Last night I cold login after changing my password, but not this morning. Can anyone here help? Is there a number to call? something???

  5. kmessinger
    Volunteer Moderator
    Posted 5 months ago #

    Have you tried:
    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). You can do this via ftp or the file manager your host provides just by renaming the plugin folder.

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  6. erinmidwife
    Member
    Posted 5 months ago #

    Thank you, I will try that.

    With plug-in problems, would I expect to find consistency? Or would it be plausible that I could login some times and not others?

  7. erinmidwife
    Member
    Posted 5 months ago #

    Is there a way to deactivate them via FTP of must I delete them? I only see an option to delete.

  8. kmessinger
    Volunteer Moderator
    Posted 5 months ago #

    Yes, you would think it would be consistent but I have given up on any an all logic long ago preferring instead luck and superstition.

    Deactivating is part of the basic debug. We are just trying to rule out possible causes.

  9. erinmidwife
    Member
    Posted 5 months ago #

    Ok, I tried the plugins.hold solution and that did not help.

    I *just* installed a new theme and if I revert back to a default theme won't I lose all my revisions?

    And in the interim people will come to my site, which will be a mess. How do people generally deal with that?

  10. erinmidwife
    Member
    Posted 5 months ago #

    i have deactivated the new theme and no change.

  11. kmessinger
    Volunteer Moderator
    Posted 5 months ago #

    All revisions should be in the database so nothing is lost.

    How many people hit you everyday? On an average site I think if it doesn't come up for someone they just try again. If it is a very popular site you would want to have a test site to look at changes.

  12. kmessinger
    Volunteer Moderator
    Posted 5 months ago #

    Are these draft posts? Tried different browsers?

    http://www.wpcypher.com/resolving-wordpress-permission-preview-drafts

  13. erinmidwife
    Member
    Posted 5 months ago #

    The issue is no longer previewing posts (though that may still persist), the issue now is that I am completely unable to login to my dashboard. I had this problem intermittantly in the past prior to installing any plugins.

  14. kmessinger
    Volunteer Moderator
    Posted 5 months ago #

    Are you still unable to log in? If so, what happens when you try?

  15. erinmidwife
    Member
    Posted 5 months ago #

    When I change my password I am *sometimes* able to login once.

    Generally what happens is, the username field is filled in with "admin." The password field is filled in with bullets. If I delete the entered password and or try to login with it - same thing happens. The screen flickers for a moment then resets to the same page with the "admin" and blank password field. No error message.

    I was able to login last night. This is how it has gone though, one login attempt is successful and subsequent attempts are not.

    I am also still unable to preview posts.

    Thank you.

  16. kmessinger
    Volunteer Moderator
    Posted 5 months ago #

    Questions: Why is your path, http://erinmidwifecom.fatcow.com/ ? Were did you get the theme Anthem?

  17. erinmidwife
    Member
    Posted 5 months ago #

    I don't know what that is my path. That is what Fatcow assigned to me?

    I obtained the Anthem theme from Theme Foundry but I have been having the preview problem prior to installing Anthem.

    I have been able to login the last few days despite having done nothing other than change passwords (again).

  18. erinmidwife
    Member
    Posted 4 months ago #

    I am still having both problems of not being able to login and not being able to preview posts. I'm so ready to quit wordpress. Just getting it to login in takes days, weeks....This is nuts.

  19. bemdesign
    Member
    Posted 4 months ago #

    I wonder if it might be a server configuration issue? Have you checked with your hosting to see what kind of help they can provide?

  20. erinmidwife
    Member
    Posted 4 months ago #

    I have, I have spent much time on the phone with them. They say since it's a WP login issue it has nothing to do with them. (Fatcow).

    I appreciate your help.

  21. Kieron Lyons
    Member
    Posted 4 months ago #

    Hi Erinmidwife,

    If you are still having trouble let me know and I will take a look at the issues you are having.
    Cheers,
    Kieron

  22. erinmidwife
    Member
    Posted 4 months ago #

    Yes, still having trouble!

  23. Kieron Lyons
    Member
    Posted 4 months ago #

    Hello Erin,

    That's disappointing but let's get you sorted out. My email is [email address moderated ] but preferably it would be best to connect via Skype so if you would not mind adding me we can take a look at your specific issues. My Skype is [moderated]

    I look forward to speaking to you soon.

    Kieron

  24. esmi
    Forum Moderator
    Posted 4 months ago #

    @Kieron: Please do not solicit contact via email. Posting your email address or asking others to contact you off forums is really frowned upon here. This is to protect users and to prevent people from trying to solicit work or harvest email addresses from the forums.

    Additionally, the point of these community-based forums is to help each other in a public space so that the whole community can benefit from the discussion and any solutions proposed. Private discussions take this benefit away. If you would prefer a one-to-one discussion, please try http://directory.codepoet.com/ or http://jobs.wordpress.net/

  25. erinmidwife
    Member
    Posted 4 months ago #

    Thanks for the offer?

  26. erinmidwife
    Member
    Posted 4 months ago #

    I'm still having the same issue. I go to my login page, enter my info, and the screen shakes for a second then the same login box appears with blank fields.

  27. erinmidwife
    Member
    Posted 4 months ago #

    ANY ideas would be much appreciated.

    One thing I have noticed, after i enter my login details and click enter, the bottom bar shows waiting for fatcow for about 2-3 seconds, then flashes back to the WP login screen.

  28. erinmidwife
    Member
    Posted 3 months ago #

    I'm sorry to keep bumping this, but, any ideas?

  29. kmessinger
    Volunteer Moderator
    Posted 3 months ago #

    Is this just the login issue now?

    Does it matter if you log in at http://erinmidwifecom.fatcow.com/wp-login.php or http://erinmidwife.com/wp-login.php ?

  30. ClaytonJames
    Member
    Posted 3 months ago #

    Apologies in advance for jumping into the mix, but could the info in this article be related at all, or at best a pointer in the right direction? When I go to my domain in a browser, I see my username.fatcow.com instead. Why is this happening?

    It looked like there might be some similarities to your symptoms; erinmidwife.com -vs- erinmidwifecom.fatcow.com, and it also appears that while you are hosted by iPage, your nameservers are at fatcow.

    It may be completely unrelated, and I understand the "username.fatcow.com" issue is probably just a normal alias, but I thought it might be worth a look.

Reply »

You must log in to post.

About this Topic