WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I dont get it? (14 posts)

  1. knckehxan
    Member
    Posted 8 years ago #

    I have uploaded all files, but get an error trying to access install.php. This is what is says at http://dogue.nu/wordpress/wp-admin/install.php

    "Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?"

    I have written my detalis as user, password, localhost and database name in wp-config. Please help....

  2. sadish
    Member
    Posted 8 years ago #

    Delete the wp-config.php and click on the install.php.

    wordpress will generate this file for you, by accepting your input. try this option.

    Thanks.

  3. Mark (podz)
    Support Maven
    Posted 8 years ago #

    If you have cpanel / plesk / vdeck or ensim, there are guides here which will help:
    http://www.tamba2.org.uk/wordpress/
    If you don't, post again ?

  4. knckehxan
    Member
    Posted 8 years ago #

    Ok I deleted wp-config.php from my server...
    This is what I got then:
    There doesn't seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file.

    So I guess that is not the solution...Shall I do something at MySQL too? I have a database there, so I thought just to write all the info to access that into the wp-config.php? Which is what I did...Please help

  5. Mark (podz)
    Support Maven
    Posted 8 years ago #

    You didn't answer my point ?

  6. knckehxan
    Member
    Posted 8 years ago #

    I am sorry, I do not even understand what you mean. I do not have cpanel / plesk / vdeck or ensim.

    What I have is an ordinary ftp with which I have uploaded the files, and a database MySQL. I was being told that it should be really easy to install wordpress, but I cant even get into the install.php page without an error:(

    *I have a database
    *I have uploaded all the files to my server

    I still do not get it....

  7. spirit892
    Member
    Posted 8 years ago #

    I know this sounds obvious, but did you edit your wp-config.php file before uploading it?

  8. knckehxan
    Member
    Posted 8 years ago #

    Yes I did, I put in all the information to access my database. Ie the same username, password and the name of my database. This is what it looks like, does it look right?

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'dogue_nu'); // The name of the database
    define('DB_USER', 'dogue.nu'); // Your MySQL username
    define('DB_PASSWORD', '*****'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

  9. spirit892
    Member
    Posted 8 years ago #

    I really don't know what else to say. You could try contacting your host to see if there is a problem with the database. Sorry, and I hope someone else can help you out.

  10. knckehxan
    Member
    Posted 8 years ago #

    Ok, but it looks right to you? I am starting to think I am the 1% regarding the "localhost"...Any suggestions on what to put there instead?
    Tks for helping

  11. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Who is your host ?

  12. knckehxan
    Member
    Posted 8 years ago #

    I think I got it?! Have a look:
    http://dogue.nu/wordpress/wp-admin/install.php

    I changed the localhost to mysql03.cliche.se...was it that simple?

    Guess not...Now I get this:
    Already Installed

    You appear to have already installed WordPress. To reinstall please clear your old database tables first.

    So what do I do now? Tks again:)

  13. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Download wp-config.php
    Open it
    Find this line:
    $table_prefix = 'wp_'
    and change it to
    $table_prefix = 'wp2_'

    and your install should be good :)

  14. knckehxan
    Member
    Posted 8 years ago #

    Great, tks a million! Seems to work now, if not I will come back:)

    Tks again!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.