WordPress.org

Ready to get started?Download WordPress

Forums

wpautop control
I do not see where I can activate it for a single page (12 posts)

  1. Svet666
    Member
    Posted 1 year ago #

    I see the settings were you can enable or disable auto-formatting for entire site but no option of disabling it for a single post.

    Hope you can help!

    http://wordpress.org/extend/plugins/wpautop-control/

  2. salvia34
    Member
    Posted 1 year ago #

    Same problem :(

  3. Shubham Kalra
    Member
    Posted 11 months ago #

    You have to enable custom fields from top(screen options) of the screen in from your posts/page editor page..

    now add a custom field wpautop and in value you can give, true or on..

    Brilliant plugin, thanks bigsmoke

  4. webmeister
    Member
    Posted 7 months ago #

    It appears I do not have the ability to enable custom fields from top(screen options)in my Paradise Theme. I will continue to look around, but if you can point me that would be great.
    So far with the plugin off, I am still getting <p> tags wrapping my jquery shortcode...

  5. ExtWP
    Member
    Posted 7 months ago #

    This is how you disable wpautop for individual posts.

    1. Go to the edit screen of any post.
    2. Below the post editor, you'll find a meta box named "Custom Fields"
    3. Using "Add custom field" section, create a custom field with the name 'wpautop' and value of 'false'.

    I'm planning on submitting some code to the plugin repository that adds a custom meta-box with a dropdown select field for controlling wpautop custom field values for individual posts.

  6. webmeister
    Member
    Posted 7 months ago #

    Thank you ExtWP. I do not have a meta box named Custom Fields. My guess is that the Paradise template does not allow it. What do you think? Maybe a plugin has removed it?

    This is on the Edit Post or Edit Page screen you are talking about right?

  7. ExtWP
    Member
    Posted 7 months ago #

    Yes, I am talking about the Edit Post or Edit Page screen.
    Since I haven't seen any of your theme's code, I can't say for sure, but I'm guessing that the theme is hiding the 'Custom Fields' meta box.

    You can modify your theme to stop this behavior or you can create a separate plugin that adds the custom field to designated posts.

    Or you can connect to the db and access the mysql tables but I don't recommend it because the risk of unintentionally breaking something is very, very high.

    Let me know if you need any help creating a separate plugin.

  8. webmeister
    Member
    Posted 7 months ago #

    Would one of the existing plugins work? i.e.
    http://wordpress.org/plugins/advanced-custom-fields/

  9. ExtWP
    Member
    Posted 7 months ago #

    Never used this one before, but it does seem like a nice (and comprehensive) plugin.
    I suggest you try it out and give this thread some feedback about how it went.

  10. bigsmoke
    Member
    Plugin Author

    Posted 7 months ago #

    Personally, I didn't even know that a theme could disable the custom fields. Is there anything a plugin author can add to his code to avoid this?

  11. ExtWP
    Member
    Posted 7 months ago #

    It could just be a visual thing like hiding the controls with javascript, but without access to the code this is just speculating. Unless the behavior is caused by an action that can be 'unhooked' with a plugin, I supposed the best solution is to find a way to work around the behavior.

    Also, I suppose that @webmeister's problem is a special case that's specific to his theme.

  12. webmeister
    Member
    Posted 7 months ago #

    Guess I could do a new install w/o any plugins just to see if "custom fields" shows up in the screen options...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.