WordPress.org

Ready to get started?Download WordPress

Forums

I changed my site and cant get in! (6 posts)

  1. KarianneH
    Member
    Posted 2 years ago #

    Ok. So I know little about wordpress and computer in general. I could not make one page be my "home" page at my site "www.kariannehorvei.com" so what I did (stupid as hell I guess), was to change my settings to "kariannehorvei.com/home" in the general settings control (I just tried something). So now if I go to http://www.kariannehorvei.com/wp-admin it automatically switches to http://www.kariannehorvei.com/home/wp-admin+++++ which do not exist. What can I do? I have the filezilla, it most be some documents I can change there?

  2. KarianneH
    Member
    Posted 2 years ago #

    Ok what I changed was wp:base_site_url and wp:base_blog_url

  3. dgilmour
    Member
    Posted 2 years ago #

    Are you using the Multisite functionality? If not, you're in the wrong forum.

    You could undo your change by using e.g. PHPMyAdmin to find the database table which holds this data, and changing it back. I guess it's probably this one, but I haven't confirmed that: http://codex.wordpress.org/Database_Description#Table:_wp_site

  4. KarianneH
    Member
    Posted 2 years ago #

    Okei. Thanks.
    Shall I change the option.php file? I found something I might have to change:

    if ( !is_multisite() ) {
    if ( !defined( 'WP_SITEURL' ) )
    $whitelist_options['general'][] = 'siteurl';
    if ( !defined( 'WP_HOME' ) )
    $whitelist_options['general'][] = 'home';

    If this is correct, what shall I change it too then?

  5. Axel13
    Member
    Posted 2 years ago #

    KarianneH, I think you should not change your files unless you do know quite a bit about it. Changing your homepage does not require you to do this, you can do this from within your WP dashboard > settings > reading

    My advice would be to change everything back to where it was and to make the desired change through the dashboard.

  6. Don't edit core files EVER unless you know exactly what you're doing, and are trying to make a patch for core.

    You will hate it when you upgrade.

    so what I did (stupid as hell I guess), was to change my settings to "kariannehorvei.com/home" in the general settings control (I just tried something).

    You know ... that's not available in Multisite, right?

    Read http://codex.wordpress.org/Changing_The_Site_URL

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.