WordPress.org

Ready to get started?Download WordPress

Forums

Mantra
[closed] I changed a theme file now can't log in as admin. HELP?? (5 posts)

  1. TerryDana
    Member
    Posted 3 months ago #

    Please I am throwing myself on your mercy here. I love this theme!
    I got my site done and it's beautiful and perfect then I went to move it and followed these directions from wordpress.org when it was moved but the links had not changed. The links changed great but now I cannot login as an admin and my users can't log in either. :(
    ----------------------------------------------------------------
    Edit functions.php

    If you have access to the site via FTP, then this method will help you quickly get a site back up and running, if you changed those values incorrectly.

    1. FTP to the site, and get a copy of the active theme's functions.php file. You're going to edit it in a simple text editor (like notepad) and upload it back to the site.

    2. Add these two lines to the file, immediately after the initial "<?php" line.
    update_option('siteurl','http://example.com');
    update_option('home','http://example.com');

    Use your own URL instead of example.com, obviously.

    3. Upload the file back to your site, in the same location. FileZilla offers a handy "edit file" function to do all of the above rapidly; if you can use that, do so.

    4. Load the login or admin page a couple of times. The site should come back up.

    5. Repeat the above steps, but remove those lines. IMPORTANT: Do NOT leave those lines in there. Remove them immediately after the site is up and running again.

    ----------------------------------------------------------------
    I'm really sorry I goofed up your theme and I won't do it again.. but any idea what I did? and how I can fix it? All I did was add 2 lines of code them take them out and now no login for me...

    I have been comparing the backup files to the "new" files and cannot find any difference.

  2. Aaron "The Monkey" Leal
    Member
    Posted 3 months ago #

    Hi Terry,

    What is the URL to the website? I will figure out what to do for you :-)

    Thanks, Aaron.

  3. jayseae
    Member
    Posted 3 months ago #

  4. TerryDana
    Member
    Posted 3 months ago #

    The test site is profile.mytwinflame.info

    The real site is UFOchick.com

    Currently the site loads perfectly on both but I cannot log in as admin on either. The bottom tabs are for registered users only so you will get a message if not logged in. That part is not broken I don't think I just can't access it.

    Thank you

  5. esmi
    Forum Moderator
    Posted 3 months ago #

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic