WordPress.org

Ready to get started?Download WordPress

Forums

Hatch
[resolved] I can't use my home page as a static page. Why? (6 posts)

  1. mgcolome
    Member
    Posted 6 months ago #

    I have a problem with my home page.

    I want to use my home page as a static page but I can't see it ok.

    For example, I like to see the home page like "strategy" page, but the text appears cut. I can not see the whole of the article. Why?

    This is the link of my page:
    http://www.needitbcn.com/wordpress/

    Anybody can help me?

    Thank you.

  2. mgcolome
    Member
    Posted 6 months ago #

    Don't worry, I've resolved the problem with a post.

    Thank you.

  3. victoriaprichard
    Member
    Posted 6 months ago #

    I am having the same problem you are! Did you just enter the information you wanted to have on the page in a post? Please advise.

  4. mgcolome
    Member
    Posted 6 months ago #

    Go to appearance > theme settings > custom css > and write this text:

    /*__________static front page: hide title__________*/
    .home.singular-page .hentry .entry-title {
    position: absolute;
    clip: rect(1px, 1px, 1px, 1px);
    }

    /*__________static front page: content fix__________*/
    .home.singular-page #content { width: 68.0851%; }
    .home.singular-page.page-template-fullwidth #content { width: 100%; }
    .home.singular-page .hentry { width: auto; height: auto; }

    Now your home page is a static page.

  5. saucer78
    Member
    Posted 3 months ago #

    I know this is marked resolved, but I've been searching for a solution to this problem for days and I'd like to thank OP for the post. I think the Hatch theme has an issue with the header not being completely disabled when no image is uploaded, which causes it to pull information into the header container when attempting to build a static page.

    I'd like to note, however, that for me, the above css had to be pasted into the editor (Appearance>Edit CSS) and not the custom css box under the Theme Settings, as instructed above. I'm very new to this and just installed and activated a child theme via a plugin, so I dunno if this is the cause of the discrepancy, but thought I'd mention it just in case anyone else stumbles across this issue...

  6. saucer78
    Member
    Posted 3 months ago #

    Just in case anyone is paying attention to this thread, I've discovered - as have others that have set their home page to static and applied this or similar tweaks - that this fix words for ALL pages, including the "Posts" page, which most people set as their blog.

    So since it reformats all pages - including the blog - the blog posts are now formatted in a column along the left side of the page, with nothing else showing up to the right. No widgets, no nothing.

    If anyone knows how to remove the posts page from this tweak, I'd be eternally grateful!

Reply

You must log in to post.

About this Theme

About this Topic