WordPress.org

Ready to get started?Download WordPress

Forums

I CAN'T UPLOAD ANY IMAGE OR PHOTO - HELP (8 posts)

  1. bamquest
    Member
    Posted 5 years ago #

    Here's the error message I'm getting:

    Unable to create directory /home/nich/public_html/wp-content/uploads/2009/03. Is its parent directory writable by the server?

    I"ve tried giving the proper permissions on those folders but I simply can't upload any photos.

    We need to get that darn thing fixed. It's been over a week now and I'm not doing any progress on that thing.

    Isn't there just one single folder where I can drop all the photos, such as wp-content/uploads? Why does it give me so many weird sub and sub-sub folders?

    The site is http://www.durhamresidentialrentals.com

    Thank YOU for any help you can offer me

  2. Samuel B
    moderator
    Posted 5 years ago #

    some servers you need to chmod /wp-content to 777 to start
    after the 1st upload usually you can chmod back to 755

  3. bamquest
    Member
    Posted 5 years ago #

    hello samboll- thanks

    but I did just what you said and I'm still getting the error meg

    I don't have anymore hair on my head now, since I've been pulling it all for the past week...

    I'm really disappointed at WordPress... I'm sure it's a small thing, but I just can't see it...

    can you help??

  4. t31os
    Member
    Posted 5 years ago #

    Assuming you have no uploads yet, delete (if it exists) the upload folder in public_html/wp-content/

    Now create a folder there called upload (in that location), give the newly created folder 777 permissions, try again..

    If that fails, delete the new folder, try again (this allows WordPress to attempt to create the folder), though this is proberly what was initially not working...

    This is not uncommon, had to do many tasks like this with various PHP and Mysql driven CMS and image scripts such as Gallery...

  5. bamquest
    Member
    Posted 5 years ago #

    hello t31os

    I did exactly what you said and the whole site was wiped out completely, so I had to re-upload it from my pc.

    Now it's back up but I'm still left with the same problem.

    So here's what I did: I changed the folder's name from wp-content to just wpcontent and it still didn't work.

    SHOULD I GIVE UP ON THIS OR WHAT????

    It's been more than a week now and I can't even start to think of the 100+ hours I've already put into that darn thing.

    Am I overlooking something here?

    HELP - HELP - HELP!!!

  6. bamquest
    Member
    Posted 5 years ago #

    can someone here help me?

  7. esmi
    Forum Moderator
    Posted 5 years ago #

    Just delete the wp_content/uploads folder. Not the whole WordPress installation!

  8. Samuel B
    moderator
    Posted 5 years ago #

    you are not changing the name of /wp-content
    just the hyphenated themes

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.