WordPress.org

Ready to get started?Download WordPress

Forums

[closed] I cant login to my admin page (36 posts)

  1. jnr4u2
    Member
    Posted 1 year ago #

    I recently added some posts to my website http://www.thepoliticaleconomist.com.ng bt as it is i cant login to my admin anymore. Whenever i type http://www.thepoliticaleconomist.com.ng/wp-admin it gives me an error that
    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
    This problem can sometimes be caused by disabling or refusing to accept cookies.
    Click here to view my php and mysql details.

    Please i will appreciate any help and i need it fast.

    Thanks

  2. WPProHelp
    Member
    Posted 1 year ago #

    Do you have a .htaccess file in the wp-admin? If yes try to remove it via FTP (keep a backup copy) and see if it works.

  3. jnr4u2
    Member
    Posted 1 year ago #

    There isn't a .htaccess file in my wp-admin folder. Just chkd it nw. Thanks. Any other idea??

  4. WPProHelp
    Member
    Posted 1 year ago #

    Ok start by disabling all the plugins then. To disable all the plugins, simply login to your website using an FTP client and rename the wp-content/plugins directory to plugins1 or something similar. Create a new empty plugins directory.

    If it works, then start enabling the plugins 1 by 1 until you find the culprit.

  5. jnr4u2
    Member
    Posted 1 year ago #

    Ive done that and im still getting the same error. Pls help.....

  6. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  7. jnr4u2
    Member
    Posted 1 year ago #

    Done that and its still giving the same error.

  8. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Do you have a .htaccess file in the wp-admin? If yes try to remove it via FTP (keep a backup copy) and see if it works.

    Look for it in the root folder. Keep in mind you have to have settings set to see all files as the file may not show up witg your file manager.

  9. jnr4u2
    Member
    Posted 1 year ago #

    When i removed it, it brought an error saying "Internal Server Error" with some other information but when i put the settings back it does the same redirecting problem again.

    Here are the settings in the .htaccess file

    # HIDE-LOGIN
    #<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^logout wp-login.php?action=logout&_wpnonce=b85710cade [L]
    RewriteRule ^admin wp-admin/ [R,L]
    RewriteRule ^login wp-login.php
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule .* //index.php [L]
    #</IfModule>
    # END HIDE-LOGIN

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  10. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I don't know what the hide login is about. Shot in the dark - try it without that part.

  11. jnr4u2
    Member
    Posted 1 year ago #

    Still the same thing. Really dont know what to do. Please help some1

  12. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Lets go back to the basic debug. I know you did the first part but did you do the second.

    Have you tried:
    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don't forget the ones in mu-plugins if you have that folder. If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.
    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

  13. PhilosopherMBA
    Member
    Posted 1 year ago #

    When I go to http://www.mypage.com/admin I get the following message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/ideas/domains/ideasmagazine.ca/public_html/wp-content/plugins/twitter-feed-scroller/ajaxtwitter.php:16) in /home/ideas/domains/ideasmagazine.ca/public_html/wp-login.php on line 362

    And then when i try to login through /wp-login
    I get all of the following:

    Warning: Cannot modify header information - headers already sent by (output started at /home/ideas/domains/ideasmagazine.ca/public_html/wp-content/plugins/twitter-feed-scroller/ajaxtwitter.php:16) in /home/ideas/domains/ideasmagazine.ca/public_html/wp-login.php on line 362

    Warning: Cannot modify header information - headers already sent by (output started at /home/ideas/domains/ideasmagazine.ca/public_html/wp-content/plugins/twitter-feed-scroller/ajaxtwitter.php:16) in /home/ideas/domains/ideasmagazine.ca/public_html/wp-login.php on line 374

    Warning: Cannot modify header information - headers already sent by (output started at /home/ideas/domains/ideasmagazine.ca/public_html/wp-content/plugins/twitter-feed-scroller/ajaxtwitter.php:16) in /home/ideas/domains/ideasmagazine.ca/public_html/wp-includes/pluggable.php on line 680

    Warning: Cannot modify header information - headers already sent by (output started at /home/ideas/domains/ideasmagazine.ca/public_html/wp-content/plugins/twitter-feed-scroller/ajaxtwitter.php:16) in /home/ideas/domains/ideasmagazine.ca/public_html/wp-includes/pluggable.php on line 681

    Warning: Cannot modify header information - headers already sent by (output started at /home/ideas/domains/ideasmagazine.ca/public_html/wp-content/plugins/twitter-feed-scroller/ajaxtwitter.php:16) in /home/ideas/domains/ideasmagazine.ca/public_html/wp-includes/pluggable.php on line 682

    Warning: Cannot modify header information - headers already sent by (output started at /home/ideas/domains/ideasmagazine.ca/public_html/wp-content/plugins/twitter-feed-scroller/ajaxtwitter.php:16) in /home/ideas/domains/ideasmagazine.ca/public_html/wp-includes/pluggable.php on line 881

    Thoughts?

  14. HenryLamPhotography
    Member
    Posted 1 year ago #

    I accidentally added "wordpress" to my URL website in the bog admin general settings, now I can't seem to get back into my blog admin panel! Please help!!

  15. racer x
    Member
    Posted 1 year ago #

    When I go to http://www.thepoliticaleconomist.com.ng/wp-login.php and I get the regular login. Maybe try deleting your cookies?

    @PhilosopherMBA, @HenryLamPhotography:
    Please start new topics. Adding to an existing topic makes reading this very confusing.

    @PhilosopherMBA - disable that twitter scroller plugin

    @HenryLamPhotography - if you can access the database, just corect that in the options table

  16. jnr4u2
    Member
    Posted 1 year ago #

    Please someone should help me out, ive not gotten anything yet. PLEASE HELP!!!!

  17. esmi
    Forum Moderator
    Posted 1 year ago #

    You need to provide more details. racer x has already said that he can access your site's login page without any problem I've just tried and got it without any problem. Both of us used http://www.thepoliticaleconomist.com.ng/wp-login.php

    So what is failing for you?

  18. jnr4u2
    Member
    Posted 1 year ago #

    I can access the page but i cant login to any account. It gives me the redirection error when i click on login. That is the problem

  19. esmi
    Forum Moderator
    Posted 1 year ago #

    OK - have you tried removing just:

    # HIDE-LOGIN
    #<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^logout wp-login.php?action=logout&_wpnonce=b85710cade [L]
    RewriteRule ^admin wp-admin/ [R,L]
    RewriteRule ^login wp-login.php
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule .* //index.php [L]
    #</IfModule>
    # END HIDE-LOGIN

    from your root .htaccess file?

  20. jnr4u2
    Member
    Posted 1 year ago #

    Ive done that and it still gives me the same error

  21. racer x
    Member
    Posted 1 year ago #

    Well, maybe a plugin keeps re-writing to it again. Are you running any kind of plugin that affects the login process?

  22. jnr4u2
    Member
    Posted 1 year ago #

    @racer x, should i give you my login details to the cpanel and wordpress account for you to see for yourself. Send me your email so i'll send them to you now. Thanks

  23. racer x
    Member
    Posted 1 year ago #

    No, sorry. I don't want that.

  24. racer x
    Member
    Posted 1 year ago #

    (I didn't mean the above negatively)

    If you can access your FTP, just take a look if there is some plugin in wp-content/plugins that has a title similar to "login".

  25. jnr4u2
    Member
    Posted 1 year ago #

    There is nothing. Ive deleted all plugins and yet i dont know why it isnt still working. Thats why i wanted to give you the wordpress account to see if it will login to the dashboard. Pls, help me. Really need it. Thanks in advance

  26. esmi
    Forum Moderator
    Posted 1 year ago #

    @jnr4u2: Please understand that racer x is trying to protect you. It really is very, very, inadvisable to give out sensitive login information to an (effectively) anonymous person on a public forum.

    Secondly, the people who help out here are unpaid volunteers. They help people to help themselves. They don't fix sites for free. If you want someone to come in and troubleshoot your site for you, I can only suggest that you consider hiring someone. Do not try to pressure forum volunteers into working on your site for you.

  27. jnr4u2
    Member
    Posted 1 year ago #

    Ok, Thanks but what do i do?? Cos im rily confused nw

  28. esmi
    Forum Moderator
    Posted 1 year ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - running the upgrade manually via wp-admin/upgrade.php

  29. racer x
    Member
    Posted 1 year ago #

    All I know is that "something" or "someone" wrote that part to your htaccess file. That is not something that the wordpress "core" did during install.

    Also, there is something called a "nonce" in that htaccess file. Nonces are security tokens that only last a short time. There would be no use to "permanently" write a nonce into any functionality. That leads me to believe that something is constantly overwriting that htaccess file. Again, I am no htaccess expert, but as others have pointed out, that section seems odd.

    I would suggest taking kmessinger's advice and try switching themes for a second. Before switching, make sure that section already suggested to remove is once again removed from the htaccess file. (in case something wrote to it agian.)

    Once we know it is the theme causing the issue, it's just a matter of possibly looking through your functions.php file for anything odd.

  30. hbasghedom
    Member
    Posted 1 year ago #

    I have the exact same problem, only mine wont load at all, before it stopped loading, i couldn't even login to my dashboard.
    HELP PLEASE!
    my website is
    http://snoosejunctionpizzeria.com
    Thank You.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.