WordPress.org

Ready to get started?Download WordPress

Forums

I can't log in through the admin page anymore (5 posts)

  1. Rocknation
    Member
    Posted 7 years ago #

    Sometimes I get the login box, but I also get these messages:

    Warning: Cannot modify header information - headers already sent by (output started at ...wp-content/themes/(rocknation)/functions.php:11) in ...wp-login.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/rocknati/public_html/wp-content/themes/(rocknation)/functions.php:11) in ...wp-includes/pluggable.php on line 329

    I ran the index page through the validator, and it says it passes tentatively because "No Character Encoding Found! Falling back to UTF-8" I presume there's a connection. What do I do about it?

  2. Samuel B
    moderator
    Posted 7 years ago #

    Actually it sounds like a plugin conflict.
    Try disabling them - then reactivate one by one, testing in between.

  3. Rocknation
    Member
    Posted 7 years ago #

    I disabled my plugins and can log in again. But the W3C validator says my doctype is either invalid or missing. Now it says

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

    Is this right? Maybe it's the reason why my style sheet validates--I have it sent to 90% of 1em)--but my type is coming out so tiny.

  4. JustinRDev
    Member
    Posted 7 years ago #

    Originally, it did sound like a plugin issue.

    At this point, I'm going to ask for a little more info - which version of WP are you using? What Plugins do you have active and how did you disable the others(renamed plugins folder or just disabled manually inside the admin panel?)

    Is the front end of the blog showing up or is it getting the same error?

  5. Rocknation
    Member
    Posted 7 years ago #

    It seems to be okay now.

    The validator didn't tell me how to fix the problem, so I just fell back on the web's golden rule: "When all else fails, copy and paste in something that works." I combined modified header information from Kubrick with my meta keywords and descriptions, and everything validates now! But will it hold up through my re-introducing my plugins and my first close encounter of the widget kind? Stay tuned, LOL!

Topic Closed

This topic has been closed to new replies.

About this Topic