WordPress.org

Ready to get started?Download WordPress

Forums

I cant log in... HELP!!! (14 posts)

  1. jbertz
    Member
    Posted 5 years ago #

    I changed the options in the site url and just could not figure out how to get the .htaccess file to work with the url I want. So i coudlnt access the blog nor could i log in. I could get to the admin login page but no matter what i typed in it would just bring me back to the admin log in page.

    I followed all the guides. Tried the theme options.php thing. I logged into my database and changed the url back to the original. still would not work.

    I upgraded to wordpress 2.7 and it still would not work. I change back to the different site url in the database and my blog works on 2.7 but i still cant log in...

    any help? I changed the password and site urls in the database and still cant log in!!

  2. supernovia
    Member
    Posted 5 years ago #

    What does it do when you try to log in? I saw this once with one of my clients - seems the solution was a combination of editing the database AND the .htaccess (also check your admin dir) but I can't remember. Knowing what it's doing currently might jog my memory.

  3. supernovia
    Member
    Posted 5 years ago #

    Also - would you happen to know whether the permalink structure setting is stored in the database or in some config file? I can't access a dev site this morning (proxy server at this location isn't recognizing the subdomain)

    I am looking to switch the permalink structure back to default so I can access via IP...

  4. jbertz
    Member
    Posted 5 years ago #

    When I try to log in it just goes back to the log in page after I click submit. I edited the database and there was no .htaccess file on my server, godaddy.

    Im not sure on the permalink structure I have yet to mess with that. Its so odd though. When I had the Home url in hte database as the original on wordpress 2.65 it worked, when I changed it to the site url I want to use it wouldnt... thats what started it all. Now i've upgraded to 2.7 and It wont work with the blog url and only with the site url that didnt work with 2.65.

  5. jbertz
    Member
    Posted 5 years ago #

    Maybe I should explain further. I have my blog hosted on an account I used to build a site for my friend. I own my own domain with google and used a url frame to map to my blog which is hosted under a different domain. In the settings I changed the url to the one I own hoping it would never show the hosted url... but that ended up in an endless loop of redirects, until I upgraded to wordpress 2.7. I have been messing with it for a few days but not until today did it not allow me to log in.

  6. supernovia
    Member
    Posted 5 years ago #

    Ahh, yeah I can see how a URL framed redirect could cause a few issues with the friendly urls. :-( In fact, by nature, a framed redirect isn't going to let you show your url at all. Click around on the site a bit and you'll likely notice that the url in the address bar always stays the same. This isn't so good for SEO or branding :-(

    Does your friend have an add-on domain he or she could lend you? That would be a far better option if you can pull it off, as the domain will be truly hosted at that point - no frames attached.

    And of course, the other option of course is to find your own hosting. There ARE free hosts out there, and some really great low-cost hosts that will support you with wordpress as well. My personal favorite: Hands-On Web Hosting -- but of course I'm biased. I work there. ;) I'd feel too spammy if I linked here, and I'm not here to advertise. But you can google us if you'd like.

  7. jbertz
    Member
    Posted 5 years ago #

    an add on domain huh? Well I went through the process of transferring my domain to godaddy to that account after being told i would be able to use it for the blog no problem.. Once I paid and set everything up they told me I had to purchase a second hosting account, so I cancelled everything. Not sure what an add on domain is but i'll look into it.

    The url frame works for me right now! I've checked out a few free hosting sites like blogetery that even do domain mapping for free, just cant put custom themes up or plugins, although they do have plugins available. Just really liked the theme I was using so im stickin with the url frame for now I guess... just gonna redo the whole damn thing...

  8. jbertz
    Member
    Posted 5 years ago #

    supernovia would you mind helping me out?

    http://www.000webhost.com offers free webhosting and serves my needs... Im trying to point my domain towards it.

    my website details are:
    server19.000webhost.com & ip: 64.235.47.65

    nameserver for the host:
    ns01.000webhost.com-----66.197.153.229
    ns02.000webhost.com-----64.235.48.196

    im not sure really where to put it in on the domain management.
    right now I have it like this:

    hostname------address----------------------------record type
    @----------------66.197.153.229------------------A(address)
    @----------------64.235.48.196--------------------A(address)
    www------------server19.000webhost.com----CNAME(alias)
    blog-------------server19.000webhost.com----CNAME(alias)

    not really sure what to put any help would be great!!!!

  9. jbertz
    Member
    Posted 5 years ago #

    well seems to be working

  10. davidilewallen
    Member
    Posted 5 years ago #

    I had a similar problem today. I changed my blogs home url to my domain name url and when i pushed save it came up with an error that said;

    "
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/1.3.33 Server at cybernautseo.com Port 80
    "

    Now I cant log in.
    I contacted my server godaddy and they couldnt help. any ideas would be apreciated

  11. jbertz
    Member
    Posted 5 years ago #

    get into your database through godaddy and open wp_options then go to the second page and you'll see home, change it back.

    hope it works for ya!

  12. davidilewallen
    Member
    Posted 5 years ago #

    is that in file manager?

  13. jbertz
    Member
    Posted 5 years ago #

    no you have to log into your database myphpadmin. go to the databases tab I believe, click mysql

  14. supernovia
    Member
    Posted 5 years ago #

    Hey there, sorry I'm not on so much over the weekend :-/

    Regarding the nameserver, unless you're using your domain across multiple servers (so unless you're using one server for mail, one server for files, one server for your site and some other server for a subdomain or something), I recommend simply pointing it to their nameservers - keeps life simpler for you as well as your host in case you have to move to another server. But what you did works too (After it propagates) so you're OK for now.

    Godaddy sucks. IMHO. :-(

Topic Closed

This topic has been closed to new replies.

About this Topic