WordPress.org

Ready to get started?Download WordPress

Forums

I can't get Facebook to see my thumbnails when I share a post from my blog (4 posts)

  1. LizCleere
    Member
    Posted 2 years ago #

    In the past couple of weeks I have had intermittent problems when sharing any post to Facebook, with no thumbnail options appearing despite there being several images in the post. Now every post I try to share to Facebook appears to have no thumbnail. This is not a Facebook fault because I am able to grab URLs from all kinds of other sites and paste them to my Facebook status with plenty of thumbnail options appearing. My site is http://www.lizcleere.com.

    Any advice would be greatly appreciated.

  2. LizCleere
    Member
    Posted 2 years ago #

    I've just been through my website, testing my posts to see if they all have the same problem. It seems that some of them when posted on my Facebook page show thumbnails, and some don't.
    I've checked the ones that work in Facebook with those that don't and there seems to be no difference. My husband has tried to link to my posts on his Facebook page and he has the same problem, with some posts showing thumbnails and others not.
    The problem is not chronological either, as some of the posts which don't work are earlier than some of the posts which do work.
    Feeling pretty dejected now.

  3. Peter J. Herrel
    Member
    Posted 2 years ago #

    You should probably implement Facebook OG (Open Graph) meta data in your WordPress header. You can start debugging your site via http://developers.facebook.com/tools/debug

  4. LizCleere
    Member
    Posted 2 years ago #

    Thanks for the speedy reply, donutz.
    I have installed WP Facebook Open Graph which I believe does exactly what you are suggesting, but it hasn't made any difference.
    I haven't yet debugged, though.

Topic Closed

This topic has been closed to new replies.

About this Topic