WordPress.org

Ready to get started?Download WordPress

Forums

WP-PageNavi
I can't find any navigation anywhere on this theme. Any Help? (5 posts)

  1. RentItToday
    Member
    Posted 1 year ago #

    First, Older and Previous doesn't appear on the theme by default so I'm not sure where to replace the code to begin with.

    There doesn't seem to be any semblance of code that resembles:

    <div class="nav-previous"><?php next_posts_link( __( '<span class="meta-nav">&larr;</span> Older posts', 'twentyten' ) ); ?></div>
    <div class="nav-next"><?php previous_posts_link( __( 'Newer posts <span class="meta-nav">&rarr;</span>', 'twentyten' ) ); ?></div>

    Just browsing around the forum it seems I should be checking index.php and functions.php so I'll post both of those here:

    INDEX

    <?php get_header(); ?>
    
    <?php $feature_posts = new WP_Query('post_type=cpo_portfolio&posts_per_page=6&order=ASC&orderby=menu_order'); ?>
    <?php if(sizeof($feature_posts) > 0): $feature_count = 0; ?>
    <div id="showcase">
    	<div class="description">
            <?php echo stripslashes(cpotheme_get_option('cpo_home_portfolio')); ?>
        </div>
        <div class="work">
    		<?php while($feature_posts->have_posts()): $feature_posts->the_post(); ?>
            <?php if($feature_count % 3 == 0 && $feature_count != 0) echo '<div class="separator"></div>'; $feature_count++; ?>
            <a href="<?php the_permalink(); ?>" class="item<?php if($feature_count % 3 == 0) echo ' item_right'; ?>">
                <div class="thumbnail">
    				<?php the_post_thumbnail(array(300, 500)); ?>
                    <div class="content">
                        <?php the_excerpt(); ?>
                    </div>
                </div>
                <div class="title">
                	<h3><?php the_title(); ?></h3>
                </div>
            </a>
            <?php endwhile; ?>
        </div>
        <div class='clear'></div>
    </div>
    <?php endif; ?>
    
    <div id="content">
    	<?php $home_posts = cpotheme_get_option('cpo_home_limit');
    	if($home_posts == '' || !is_numeric($home_posts)) $home_posts = 5;
    	query_posts('posts_per_page='.$home_posts); $post_count = 1000; ?>
    	<?php while(have_posts()): the_post(); ?>
    	<div class="preview">
            <div class="meta">
                <div class="thumbnail"><?php the_post_thumbnail(array(300, 800)); ?></div>
                <div class="date"><?php the_date(); ?></div>
                <div class="tags"><?php cpotheme_post_tags(); ?></div>
                <div class="comments"><?php if(get_comments_number() == 1) _e('One Comment', 'cpotheme'); else printf(__('%1$s Comments', 'cpotheme'), number_format_i18n(get_comments_number())); ?></div>
            </div>
            <h2 class="title">
                <a href="<?php the_permalink(); ?>" title="<?php printf(esc_attr__('Permalink to %s', 'cpotheme'), the_title_attribute('echo=0')); ?>" rel="bookmark"><?php the_title(); ?></a>
            </h2>
            <div class="byline"><?php cpotheme_post_shortbyline(); ?></div>
            <div class="content"><?php the_excerpt(); ?></div>
    	</div>
    	<?php endwhile; ?>
    </div>
    
    <?php get_sidebar('home'); ?>
    <?php get_footer(); ?>

    FUNCTIONS

    <?php //CPO Framework for WordPress
    
    add_theme_support('post-thumbnails');
    add_theme_support('automatic-feed-links');
    if(!isset($content_width)) $content_width = 960;	
    
    //Load Core; check existing core or load development core
    if(defined('WP_CPODEV'))
    	require_once(get_template_directory().'/../cpoframework/core/init.php');
    else
    	require_once(get_template_directory().'/core/init.php');
    
    $include_path = get_template_directory().'/includes/';
    
    //Main components
    require_once($include_path.'setup.php');
    
    //Metadata & variables
    require_once($include_path.'metadata/data_general.php');
    require_once($include_path.'metadata/data_metaboxes.php');
    require_once($include_path.'metadata/data_settings.php');
    
    //Layout & Display components
    require_once($include_path.'layout/layout_login.php');
    require_once($include_path.'layout/layout_post.php');
    require_once($include_path.'layout/layout_breadcrumbs.php');
    require_once($include_path.'layout/layout_comments.php');
    require_once($include_path.'layout/layout_general.php');
    
    //Custom posts
    require_once($include_path.'cposts/cpost_slider.php');
    require_once($include_path.'cposts/cpost_features.php');
    require_once($include_path.'cposts/cpost_portfolio.php');
    
    //Custom taxonomies
    require_once($include_path.'taxonomies/tax_portfolio_cats.php');
    
    ?>

    Using this theme:
    http://www.cpothemes.com/theme/panoramica

    Thanks in advance - I've been staring at this stuff for hours. =)

    http://wordpress.org/extend/plugins/wp-pagenavi/

  2. That's not a theme we support in these forums. Try the theme's support link instead.

    http://www.cpothemes.com/support

    Generally speaking you're looking for the right code per the installation page.

    http://wordpress.org/extend/plugins/wp-pagenavi/installation/

    But the author of that theme would be the best person to ask about adding WP-PageNavi successfully to that theme.

  3. RentItToday
    Member
    Posted 1 year ago #

    Thanks for the response, I tried contacting them prior to asking here. I still haven't heard a response.

    Typically speaking can I just add the code myself manually anywhere? Or will that require a little more familiarity with coding (multiple steps)?

  4. yajanssen
    Member
    Posted 1 year ago #

    Re: http://www.ctproductsandservices.com
    Problem Page: http://ctproductsandservices.com/custom-post-types-landing-page/?landing_page=listing
    I would like to paginate it, since it is too long and it gives an error message.
    http://screencast.com/t/JUeQ9jsqTf
    I was told by woothemes tech to get WP-PageNavi.
    I uploaded, followed instructions for installation and usage.
    Add <?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?> in Listings: footer.php
    What am i missing?

  5. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    @yajanssen

    please start your own topic.

    you are using a different theme and your problem is different from the current topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic