WordPress.org

Ready to get started?Download WordPress

Forums

I can't edit the permalink for my new post! (16 posts)

  1. admin@womem
    Member
    Posted 2 years ago #

    I am trying to create a new post but each time it automaticall creates a permalink which is idendtical to a staic page that already exists on the site and therefore rather than showing the full post it redirects people to a totally different page! how can I change this??

    http://www.dayofwomen.org/category/blog this is the preview of the post that shows under the 'blog' category - but when you click on the link to read more it takes you to http://www.dayofwomen.org/about

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Try giving the post a slightly different title.

  3. admin@womem
    Member
    Posted 2 years ago #

    I have already tried adjusting the title but for every new post I create the same thing happens.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    No - not adjusting the title on a post you have already published. Delete that post, empty your post Trash and re-publish it using a slightly different title.

  5. admin@womem
    Member
    Posted 2 years ago #

    Ok I just emptied my trash and also recreated the category but still it creates a permalink identical to that of our About page

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    What is this post's url?

  7. admin@womem
    Member
    Posted 2 years ago #

    It is automatically creating one http://www.dayofwomen.org/about

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  9. admin@womem
    Member
    Posted 2 years ago #

    thank you i will try all of the above!

  10. admin@womem
    Member
    Posted 2 years ago #

    I have tried all of the above (including deleting the inactive plugins entirely) and still each time - even when using the twentyeleven theme each new post autosaves with the same url.

  11. admin@womem
    Member
    Posted 2 years ago #

    I have even tried deleting the page that the the posts keep linking too and it still occurs - however now as the page no longer exists it is saying no posts found when you click read more.

  12. esmi
    Forum Moderator
    Posted 2 years ago #

    What is the title of this post?

  13. admin@womem
    Member
    Posted 2 years ago #

    Your Inner Voice: Friend or Foe?

    But even when I tried using something similar or entirely different it still didn't work

  14. esmi
    Forum Moderator
    Posted 2 years ago #

    Try resetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  15. admin@womem
    Member
    Posted 2 years ago #

    That's done it! Thank you very much!

  16. geekygordon
    Member
    Posted 2 years ago #

    Nice one Esmi - thanks for the tip - I was looking for this too.

Topic Closed

This topic has been closed to new replies.

About this Topic