WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I can't change *ANY* settings in the backend :O (22 posts)

  1. online
    Member
    Posted 3 years ago #

    I changed "Remote Login" to off the other day and was trying to get a privacy plugin working -- I thought everything was fine, but then all of a sudden an "unknown error" came up for new posts / comments.

    Now I can't seem to change any settings in the backend :|

    WTH?!?!

  2. online
    Member
    Posted 3 years ago #

    right, exactly

  3. All Remote Login SHOULD do is make your login pages for all sites redirect to your main site to do the actual login.

    Try deleting your cookies and cache and going back in?

  4. online
    Member
    Posted 3 years ago #

    I already did that -- but that doesn't change anything.

    I can't deactivate plugins, can't change the domain mapping settings -- I have no idea what is going on! :(

  5. You can deactivate plugins via FTP, by removing them from the plugins folder... I would delete the one(s) you installed for the privacy plugin?

    Also, which plugin was that? It could have buggered things.

  6. online
    Member
    Posted 3 years ago #

    more-privacy-options -- I added it to the tags

    I moved it out into a non WP folder, then it said it was disabled because it didn't exist -- but it didn't change anything about the inability to change settings.

    I reinstalled it again (through the backend), hoping then I might be able to disable it, but that also didn't work. :/

  7. online
    Member
    Posted 3 years ago #

    oh, I just tried to delete a plugin that was disabled (wasn't planning to use it anymore, so it was a good test-case) -- and that got deleted OK! (woohoo)

    When I attempt to disable more-privacy-options, I get the message saying it was disabled -- but it's *not actually* disabled. :|

  8. online
    Member
    Posted 3 years ago #

    tried disabling another active plugin (login-configurator) and it's the same problem -- it says it's disabled, but it isn't. Can't change the settings in any plugins whether in the plugins directory or the domain mapping in the mu-plugins directory

  9. Look in your mu-plugins folder.

  10. online
    Member
    Posted 3 years ago #

    just domain-mapping in there

    btw: should sunrise.php have permissions set to 640 or 644?

  11. online
    Member
    Posted 3 years ago #

    should more-privacy-options be in the plugins directory or in the mu-plugins directory?

  12. David Sader
    Member
    Posted 3 years ago #

  13. online
    Member
    Posted 3 years ago #

    ACK -- so is that the problem?

    I installed this via the backend (which is probably why it went into the plugins folder).

    So what do I do now? I've tried pushing more-privacy-options into mu-plugins, but that doesn't seem to do much.

  14. Disable *all* your plugins - everything in the plugins folder AND the mu-plugins folder.

    then see if the issue goes away.

  15. David Sader
    Member
    Posted 3 years ago #

    it didn't change anything about the inability to change settings

    This issue must be fixed before installing anything.

    FYI, domain mapping may not be compatible with the privacy plugin, or any other plugin that modifies the original location of the the login form.

  16. online
    Member
    Posted 3 years ago #

    If the two are not compatible, is it possible to use mapping on some blogs, and then on blogs not using mapping (i.e., in which the standard site address is used as primary address) to use a privacy plugin -- for example the network-privacy plugin?

  17. As far as I know, both domain mapping and the privacy plugins are able to work together.

    You really need to disable every single plugin and see if "unknown error" still comes up for new posts / comments.

  18. online
    Member
    Posted 3 years ago #

    Yea, I have been trying that -- do you mean just to move the plugins out of the directories? I tried plain disabling and moving them out, but not with all of them. I am beginning to think that dropping the privacy plugin into the regular plugins folder did "irreparable damage" (and that I may have to start over from scratch -- i.e. restoring from backups, etc.)

  19. online
    Member
    Posted 3 years ago #

    (note also my comments above about not being *able* to disable plugins)

  20. Standard procedure for disabling plugins is to go in via ftp and rename the plugins folder. that disables them all at once. Do the same for the mu-plugins folders. comment out the define sunrise line in wp-config for the domain mapping.

    that gets you as close to possible to a vanilla install.

    knowing how the privacy plugins work, I can't think of anything it does specifically that woudl do this. I *can* see some plugin conflicts mucking things up tho.

    thus the suggestion to disable them. All of them.

  21. online
    Member
    Posted 3 years ago #

    One thing about wordpress: It's so easy to restart (which I did), that if a big problem comes up then that seems to be the easiest + most effective method to fix it.

    I think basically this was my error of doing something wrong (like installing "more privacy" in the regular plugins folder -- or something like that.

    So I consider this more or less resolved -- thanks for all of your help! :)

Topic Closed

This topic has been closed to new replies.

About this Topic