WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] I cannot get rid of index.php in permalinks & .htaccess (7 posts)

  1. BLUE_LIFE
    Member
    Posted 3 years ago #

    Hi
    I am trying to change my url into pretty permalinks.
    So far , if I use the basic config of wordpress like
    http://www.mysite.com/myblog/index.php/2010/08/14/sample-post/
    it works.
    NOTE : no .htaccees file was needed at this point.

    But this is not exactly what I want. I do not want the index.php appearing in the URL.
    So when I try to put in the custom field : /%postname%/ it does not work. As a consequence I followed the wordpress help on this matter, as well as many other articles on the subject and uploaded in my blog directory the following .htaccess file rule:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress

    But I get an 404 error page.

    For info, my blog is is a subdirectory...if this help.
    Could it be that my .htaccess file rule is wrong ?

    THANK YOU !!!!!

  2. The .htaccess above is wrong; it's for a site not in a subdirectory. Go to Dashboard/Settings/Permalinks and set your permalinks that way, and be sure wordpress says it was able to update .htaccess and .htaccess was writable. Using Permalinks « WordPress Codex

  3. BLUE_LIFE
    Member
    Posted 3 years ago #

    Hi Songdogtech
    Well, I am not sure I get everything you wrote...
    But YES my permalinks are set to /%postname%/

    And NO, nowhere I can see that wordpress

    wordpress says it was able to update .htaccess and .htaccess was writable.

  4. BLUE_LIFE
    Member
    Posted 3 years ago #

    no. Apache :-)

  5. Make sure your .htaccess is writable with your FTP client: http://codex.wordpress.org/Changing_File_Permissions

    Or delete the one you uploaded and let WordPress regenerate it.

  6. BLUE_LIFE
    Member
    Posted 3 years ago #

    It is solved. Was just a path error from myself...

Topic Closed

This topic has been closed to new replies.

About this Topic