WordPress.org

Ready to get started?Download WordPress

Forums

I can change permalinks in my pages but not with my posts (7 posts)

  1. CaptureFactory
    Member
    Posted 2 years ago #

    I have custom permalinks for all my 'pages' and have been able to edit them easily. My issue is, I cannot edit my 'post' permalinks. There is no 'edit' button available either like there is on my page edit options. This wouldn't be too much of an issue but any new posts created are assigned my home page address and so can never be created or viewed.

  2. flamenco
    Member
    Posted 2 years ago #

    That's odd, I can edit my links for Posts or Pages. (I can't override the permalink base, though).

    Assuming you have the latest version of WP, my guess is that either you have a plugin that has borked link editing on Posts, or maybe your log-in is at a lower authority level, putting a stop to that? A super admin should typically be able to edit all that.

    Good luck, D

  3. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  4. CaptureFactory
    Member
    Posted 2 years ago #

    Thanks for replies so far.

    I switched between the theme's, deactivated any plug-ins and reset the plugins folder, this did nothing.

    Any other ideas I could try.

    Many thanks.

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    any new posts created are assigned my home page address

    Why? What custom permalink structure are you using? Try resetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  6. CaptureFactory
    Member
    Posted 2 years ago #

    Thanks for the link. It states:

    'You never, ever put your site url in the permalinks slot. You must use one of the structure tags, or a combination of tags only.'

    I don't know for sure, but I might have done this early on in my site building career by mistake. If I revert back to default will this undo any errors I may have inadvertently caused?

  7. esmi
    Forum Moderator
    Posted 2 years ago #

    It should do, yes.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.