WordPress.org

Ready to get started?Download WordPress

Forums

I can´t access anything anymore after changing permalink to date and namebased (7 posts)

  1. JoSimon
    Member
    Posted 8 years ago #

    Big Problem:
    I just changed permalink from default to Date and name based

    » http://www.soulvista.de/wordpress/2006/04/13/sample-post/

    after klicking the safe button the css disappeared and th page was naked. After trying to undo it by safing the default I got a problem:

    now I can´t access anything anymore!

    I always reveive this on my screen:
    Forbidden

    You don't have permission to access /wordpress/wp-admin/... on this server.

    Apache/1.3.29 Server at http://www.soulvista.de Port 80

    or even:
    Forbidden

    You don't have permission to access /wordpress/ on this server.

    Apache/1.3.29 Server at http://www.soulvista.de Port 80

    So I have no access to my site anymore except via ftp

    I can not change the permalink back to default via the tick-box.

    Help please!!!
    -------------
    I am using wp 2.0.2
    I have the new sirius theme installed

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Using ftp, rename the .htaccess file to htaccess.txt
    Does that allow you access?

  3. JoSimon
    Member
    Posted 8 years ago #

    Well I don´t know how to do that. I use a mac and if I download the .htaccess with my client called cyberduck it just disappears... what works is to just erase the .htaccess . But then I still have trouble with it. Anytime I enter the permanentlinks- panel I have to erase the .htaccess afterwards again. I have switched the whole directory to 777 now to make shure no problems come from that side. Is ist a bug or serverrelated?

  4. iand
    Member
    Posted 8 years ago #

    For renaming files with Cyberduck - just select the file in question, hit Cmd+I, edit the name in the info-box and hit return.
    .filename files don't show up by default on OSX but use this and they will most likely be sitting on your desktop.

  5. JoSimon
    Member
    Posted 8 years ago #

    Hi, I managed to open the .htaccess ( I ended up using a program called transit )
    this is what it says ...

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    What does it mean and how should I proceed?

    I am still sarting so in worst case I could delete everything inclusive the database...
    and I already did this but whilst clicking to permalinks it happened again!
    I hope you can help me further on! Thnx!

  6. JoSimon
    Member
    Posted 8 years ago #

    and yes to podz: if I rename it to htaccess.txt I have access but by the time i enter the permalinks - site there is a new .htaccess ... and on the permalinks site (i.g. where you can change the permalink-settings) I see no style, like without css.

  7. JoSimon
    Member
    Posted 8 years ago #

    Hey guys I did it all again and I did not touch permalinks this time and I did not touch flickr album and it works now. Falbum is ok and does not require the change in permalinks.
    what was wring i dont know but i will not touch permalinks again. never.

Topic Closed

This topic has been closed to new replies.

About this Topic