WordPress.org

Ready to get started?Download WordPress

Forums

I broke my website (13 posts)

  1. Juttas
    Member
    Posted 1 year ago #

    Hi,

    I am feeling very stupid and I do hope that someone can help me. I was trying to move my website out of a subfolder it is sitting in (don't ask!) and I think I may have managed to move a file into the wrong folder or something. The front page is still there but as soon as you try to click through to another page all you get is a 404 error page.

    I'm really not sure what I've done or how to fix it any help would be much appreciated.

    the website is http://www.stillerdesigns.co.uk

    Thanks,

    Jutta

  2. Juttas
    Member
    Posted 1 year ago #

    I have been looking at other posts on this page and found something similar mentioning a .htaccess file, when I search for this it says I have 2 but when I click for it to show me there is nothing there. Is this a hidden file?

    Thanks,

    Jutta

  3. darrenmeehan
    Member
    Posted 1 year ago #

    Its more than likely your .htaccess file. Simply move it into the same folder as your wp files - i.e your wp-config.php etc.

    The dot infront of the files means its hidden so you'll have to set your ftp program to show hidden files if you want to see it.

  4. Juttas
    Member
    Posted 1 year ago #

    Ok I understand what you're saying, I'm working through cpanel and I can't get the pop up window to come back so I can choose to see the hidden files even the reset all interface settings link is not working.

    I have managed to see the file via Fireftp and I moved it into the folder you suggested, thing is the image on the front page has disappeared and the links still don't work.

    Thanks,

    Jutta

  5. darrenmeehan
    Member
    Posted 1 year ago #

    Try going to Settings > Permalinks and copying the code it shows there into your .htaccess

  6. Juttas
    Member
    Posted 1 year ago #

    I followed your advice in the other post re the .htaccess file (putting that code into it) and now the image is back but the links aren't working.

    Could I have messed something up in the theme? although the front page looks perfectly normal, well as it should, to me.

    Thanks,

    Jutta

  7. darrenmeehan
    Member
    Posted 1 year ago #

    what url structure have you set in Settings > Permalinks ?

    Sorry, its been awhile since I've had an error like this and I cant think of what solution is most likely!

  8. Juttas
    Member
    Posted 1 year ago #

    Do you mean within the theme? If I could remember that I'd be laughing! I can't get to the page to sign into the wordpress dashboard, I don't know anyother way of accessing it other than the link on the blog page of my website that I can't access.

    I know its something I've done as it was only after I tried to move the files I had this problem.

    Thanks,

    Jutta

  9. Juttas
    Member
    Posted 1 year ago #

    AHA! I've managed to get into the dashboard via a link in the history of the browser :o)

    The permalinks are set as post name :- http://stillerdesigns.co.uk/blog/sample-post/

    Does that help at all?

    Thanks,

    Jutta

  10. darrenmeehan
    Member
    Posted 1 year ago #

    Your Dashboard can be found at http://stillerdesigns.co.uk/blog/wp-admin, which I believe means your blog is installed at /blog/ on your server.

    The links in your menu all seem to be working fine now!

  11. Juttas
    Member
    Posted 1 year ago #

    You know what I could kiss you I'm so relieved (don't worry I'm female!!!)

    Ok so one last thing if I may, I want to move the whole thing so that its not .co.uk/blog but is .co.uk this is what I was trying to do this morning (famous last words!) can I just copy everything across? or should I be doing something else?

    Thanks,

    Jutta

  12. Juttas
    Member
    Posted 1 year ago #

    Oh and now I'm going to back it all up properly :o)

    Thanks,

    Jutta

  13. darrenmeehan
    Member
    Posted 1 year ago #

    aha thanks that's awesome to hear! :P

    If its just the url you want changed, and you don't mind what folder your WordPress files are in, then go to General > Settings

    Your blog url from http://stillerdesigns.co.uk/blog/

    to http://stillerdesigns.co.uk/

    You're merely removing the blog/ part from it!

    I think its a good idea to backup your site too! something like https://codeguard.com/ could work well for you

    Hope that helps :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.