WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form DB
I am no longer receiving the emails from my contact forms.... (17 posts)

  1. paintandpour
    Member
    Posted 1 year ago #

    They appear in the Contact Form DB, but are not forwarded to the email. Is this working as intended? I want both, a separate email DB of all contacts, and to receive them in my email as per standard contact form procedures.

    Thank you for your assistance!

    http://wordpress.org/extend/plugins/contact-form-7-to-database-extension/

  2. Michael Simpson
    Member
    Plugin Author

    Posted 1 year ago #

    CFDB should not interfere with emails. Try temporarily disabling CFDB and do a form submission. If you get an email only with CFDB disabled, then we know CFDB is causing the problem.

  3. donbucknall
    Member
    Posted 1 year ago #

    I have this same problem. with the plugin enabled, I don't get an e-mail but it is submitted to the database. However I also have people add an attachment which is not mailed and also not added to the database.

    With the plugin disabled, it does send the e-mail with attachment.

    Is there any way to solve this?

    Thanks, Don

    ---------

    Forgot to mention that it worked perfectly before!

  4. donbucknall
    Member
    Posted 1 year ago #

    After some testing, I found out that if I take out the file attachment bit. Mails are sent and added to the database. So there is a problem with the attachments.

    I have never had this before. However I used this alot last year for a project and the project is again this year. So I guess there is something with an update.

    Thanks again!

  5. donbucknall
    Member
    Posted 1 year ago #

    Anyone?

  6. donbucknall
    Member
    Posted 1 year ago #

    After some trying and testing again, I realised small files work. They get sent and uploaded in the database. But larger files 1MB + they get stuck. I changed the php.ini file. Is there anything else I should check?

  7. Michael Simpson
    Member
    Plugin Author

    Posted 1 year ago #

    In Contact Form 7, I think there is a 1Mb default size limit on file uploads which you can change simply by adding a max size to the field definition. (You will have to look that up).

  8. donbucknall
    Member
    Posted 1 year ago #

    That is set to 7mb. So it's not the setting. :(

  9. Michael Simpson
    Member
    Plugin Author

    Posted 1 year ago #

    I'll try to find some time within the next week to see if I can duplication and fix the issue.

  10. Dominique
    Member
    Posted 1 year ago #

    Hi
    I made the CFDB update on several websites and actually I have the same problem everywhere. This was the only plugin that I updated yesterday night and since then all data submitted by users are available in the database but emails are NOT sent, and this is on several different servers.
    dom

  11. Dominique
    Member
    Posted 1 year ago #

    Hi again
    I downgraded to 2.4.8 and on my 3 websites it works again...
    dom

  12. donbucknall
    Member
    Posted 1 year ago #

    Sweet news Dominique! Where do I find the 2.4.8 and how do I downgrade?

    Don

  13. Dominique
    Member
    Posted 1 year ago #

  14. donbucknall
    Member
    Posted 1 year ago #

    Thanks! I tried 2.4.8 , 2.4.7 , 2.4.6 and 2.4 but all the same problem. It keeps spinning like it's sending. It adds the form to the database without the attachment and doesn't e-mail.

    If the file is smaller then 1mb it works and if I disable the CFDB plugin it e-mails.

    Thanks for the help anyways!

  15. Michael Simpson
    Member
    Plugin Author

    Posted 1 year ago #

    The best I can figure is that larger files are causing the plugin to run out of memory.

    I think the scenario is:
    - Form is submitted
    - CF7 calls a hook just prior to sending email; this is were CFDB hooks in
    - CFDB saves the regular form data to the DB
    - CFDB reads the file into memory and tries to save it to the DB
    -- I think here it runs out of memory and dies.
    -- This prevents CF7 from continuing and sending mail

    You can try increasing the memory limit for WordPress.

  16. donbucknall
    Member
    Posted 1 year ago #

    Ok, I have set the config file, but it hasn't changed anything. How can I make sure it has accepted the changes? How can I check the php settings?

    Thanks for the help!

  17. donbucknall
    Member
    Posted 1 year ago #

    Ok, found it.
    Memory limit is 128M and postmaxsize 32M and uploadmax 32M.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.