WordPress.org

Ready to get started?Download WordPress

Forums

I am getting this error (11 posts)

  1. runningblogfather
    Member
    Posted 6 years ago #

    I have (I think!) followed all the right steps but I always get this when I post:

    Warning: unlink(/home/crunning/public_html/wp-content/cache/wp-cache-ea64daffa3bb90e7c0a96889ea739090.html) [function.unlink]: No such file or directory in /home/crunning/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 429

    Warning: Cannot modify header information - headers already sent by (output started at /home/crunning/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php:429) in /home/crunning/public_html/wp-includes/pluggable.php on line 391

    Any ideas? Thanks!

  2. Jason Pelker
    Member
    Posted 6 years ago #

    I'm getting the same error. Has anyone come up with a solution?

  3. jnagyjr
    Member
    Posted 6 years ago #

    I'm also getting an error when I try to post (after having run the upgrade.php script). The error I get is as follows:

    WordPress database error: [Table 'dbname.wp_post2cat' doesn't exist]
    SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM wp_posts p LEFT JOIN wp_post2cat pc ON p.ID = pc.post_id LEFT JOIN wp_categories c ON pc.category_id = c.cat_ID WHERE post_status = 'publish' GROUP BY cat_ID

    I upgraded via Fantistico via my host, BlueHost.

    Before I upgraded, I had no problems posting to WordPress.

  4. moshu
    Member
    Posted 6 years ago #

    Read the "sticky" post on the main page of the forum: incompatible theme or plugin.

  5. Donncha O Caoimh
    Member
    Posted 6 years ago #

    runningblogfather - does that message appear every time you post or just sometimes? Are you using suphp? Are you using apache and mod_php?

    jnagyjr - that error isn't related to WP Super Cache :)

  6. Jason Pelker
    Member
    Posted 6 years ago #

    I receive this error sporadically. It was almost constant at first. Now it occurs on the first saves (and continue), but likely not with the second. I can't really find a pattern--whether it happens only when the content changes or whatnot. It's more likely to happen after I wait a bit, as well.

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-225e8ee2f71fe5d884e512bc1205947d.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: Cannot modify header information - headers already sent by (output started at /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php:433) in /home/jpelker/public_html/wordpress/wp-includes/pluggable.php on line 391

  7. Donncha O Caoimh
    Member
    Posted 6 years ago #

    jpelker - is your host on an NFS server, and are you using flock? You should try semaphore file locking if you are.

  8. Jason Pelker
    Member
    Posted 6 years ago #

    @donncha:

    I'm trying to pry this info from my web hosts and I'll keep the thread notified once I find out the deal.

    Just wanted to update that I also see errors on comment posts:

    `
    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-56c64910f05336759b8770b4de2a407d.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-91f0e287e21b7685d5abd0db960bcfb4.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-6cdc5cc5e30f20cc0f0387bf4d3c7ae7.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-10d73387b864664d28656d5596807c23.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-cf9b1b08e7928e3828e0e3022bfb40f4.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-78d8b82f74a4f1231982074f70aef220.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-081e83d665149ca023ede786b8dd5977.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-bdbb775127c810048a2aeb2a1873416e.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-0ebd69230e5097fe9ff1e418ecb09f62.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-cf87545865653299fac43166656f91ba.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-c156d3c08cd5300ea005d8e2d7442669.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: unlink(/home/jpelker/public_html/wordpress/wp-content/cache/wp-cache-6470f501fc82c682b5c90be269475894.html) [function.unlink]: No such file or directory in /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 433

    Warning: Cannot modify header information - headers already sent by (output started at /home/jpelker/public_html/wordpress/wp-content/plugins/wp-super-cache/wp-cache-phase2.php:433) in /home/jpelker/public_html/wordpress/wp-includes/pluggable.php on line 391`

  9. Jason Pelker
    Member
    Posted 6 years ago #

    From the host:

    "There is no nfs on the server.

    Please take a note that we do not support 3rdparty software and don't do any script reconfigurations.

    You can upload your custom php.ini file that contains your custom php settings.

    Please take a note that it should be put in every folder where php scripts are expected to be run.

    We can upload a sample of the php.ini file to your public_html if it's needed.

    Thank you for your cooperation."

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Just edit the wp-cache-phase2.php file, find the "unlink()" command on line 433, and stick an @ in front of it. Like so:
    @unlink(whatever);

    Problem solved. You're getting the warning because it's trying to delete files that don't exist. Well, okay, I don't know why it's doing that, but it's not exactly an "error", is it? The files don't exist and it wanted to delete them. Seems like a non-problem, eh?

    Just add the @ to suppress the warning and get on with life.

  11. Jason Pelker
    Member
    Posted 6 years ago #

    Cue Bette Midler...

    Did you ever know that you're my hero? You're everything I wish I could be. I can fly higher than an eagle because you are the wind beneath my wings.

    *ISSUE RESOLVED*

Topic Closed

This topic has been closed to new replies.

About this Topic