WordPress.org

Ready to get started?Download WordPress

Forums

I am getting a strange bug / Codium Extend theme (9 posts)

  1. AmiV2
    Member
    Posted 3 years ago #

    When the blog first comes up, it seems like a </style> tag is dropped. This happens just before the </head> tag.

    Now this is STRANGE:

    If I log into the blog as admin, the tag "comes back". Code is:

    <style type="text/css">
    div#header {
    background: url(http://blog.stockpair.com/wp-content/uploads/2011/03/sp_logo_white_980x1502.jpg); height :130px; -moz-border-radius-topleft:6px;border-top-left-radius:6px;-moz-border-radius-topright:6px;border-top-right-radius:6px;
    }
    h1.blogtitle,.description { display: none; }
    <style type="text/css" media="print">#wpadminbar { display:none; }</style>
    <style type="text/css">
    html { margin-top: 28px !important; }
    * html body { margin-top: 28px !important; }
    </style> <<<<<==== this is the once that is dropped off

    </head>

  2. David Gard
    Member
    Posted 3 years ago #

    Do you mean when you log in and then view the blog it comes back, or that the back-end is ok? If it's the latter, then that would be expected behaviour as the admin area uses different style sheets to your blog.

    If this has only started happening since you upgraded to WP 3.1, then maybe try adding wp_footer(); to your 'footer.php' file (if it is not already there), as there have been some strange errors reported due to this line missing and the new admin-bar being introduced in to WP 3.1.

  3. AmiV2
    Member
    Posted 3 years ago #

    I meant when I DO NOT LOG IN, that means when other look at the blog. There is definitely a missing </style> missing. This happened with two people and with a bunch of different browsers.

    I will try the wp_footer(); // but this does not seem to be related. The missing tag seems to be in the header.php file.

    It was happening just before the 3.1 update. So I updated, and it behaves the same. I guess that does not help much, sorry :(

  4. AmiV2
    Member
    Posted 3 years ago #

    Hi duck__boy, the footer already has the call, it looks like this:

    <div id="footer"> Copyrights © 2010 Stockpair All Rights Reserved         US Patent Pending
    <?php wp_footer() ?>
    </div>
    </body>
    </html>

    is there a place I can search for missing </class> tag ?

  5. davidzuhn
    Member
    Posted 3 years ago #

    I'll bet you have the title in the your header image turned off.

    I had to put this patch in place:

    --- /Users/zoo/wordpress/codium-extend/functions.php	2011-02-25 13:01:39.000000000 -0600
    +++ functions.php	2011-03-13 21:09:07.000000000 -0500
    @@ -24,7 +24,7 @@
             }
             <?php if ( 'blank' == get_header_textcolor() ) { ?>
     		h1.blogtitle,.description { display: none; }
    -		<?php } else { ?>
    +    </style><?php } else { ?>
     		h1.blogtitle a,.description { color:#<?php header_textcolor() ?>; }
         </style><?php
     		}
  6. AmiV2
    Member
    Posted 3 years ago #

    Hi David, Thanks for the fix. Where do I get it? Did you put it into the next version of the theme? Do I just download and replace the functions. php file or update the whole theme?

    I tried copying the code into the functions.php and took out the + and - and got an error. What do I do? anything else to do?

  7. AmiV2
    Member
    Posted 3 years ago #

    help, I tried changing the functions.php file back and still get the error:

    Parse error: syntax error, unexpected T_ELSE in /home/content/03/7528803/html/wp-content/themes/codium-extend/functions.php on line 28

    Now nothing works. How do I get back to at least the last config?

  8. henri
    Member
    Posted 3 years ago #

    In functions.php update this

    // gets included in the site header
    function header_style() {
        if (get_header_image() != ''){
        ?><style type="text/css">
            div#header {
                background: url(<?php header_image(); ?>); height :230px; -moz-border-radius-topleft:6px;border-top-left-radius:6px;-moz-border-radius-topright:6px;border-top-right-radius:6px;
            }
            <?php if ( 'blank' == get_header_textcolor() ) { ?>
    		h1.blogtitle,.description { display: none; }
    		<?php } else { ?>
    		h1.blogtitle a,.description { color:#<?php header_textcolor() ?>; }
        	<?php
    		} ?>
    		</style><?php
    		}
    	}
  9. henri
    Member
    Posted 3 years ago #

    Or use the 1.0.9 (online in few hours)

Topic Closed

This topic has been closed to new replies.

About this Topic