WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] hyperlinks not properly linking to my entered URL (4 posts)

  1. brianbotkiller
    Member
    Posted 1 year ago #

    Hi all,

    For some reason, I have a grip of pages that, even though I've hard coded a URL into an image, that image is pointing to a entirely different URL. I can't see any reason for this. I had an issue wherein I had to change urls from http: to https:, so I used search and replace (WP plugin) to make those changes in the database. However, now, these images, while linked to the proper URL in my page code, are refusing to link to my hardlinked URL.

    The page in question is here: https://www.obedia.com/presonus-manual

    The image which says, "create your account today", should hard link to https://panel.obedia.com/client_register/clientReg.cfm

    However, it's hard linking to https://www.obedia.com/panel.obedia.com/client_register/clientReg.cfm

    no matter what.

    I can't see ANY reason for this, I have cleared browser caches and such, and this is something happening in WP itself.

    Help, please!

  2. OurWebSupport
    Member
    Posted 1 year ago #

    Hi brianbotkiller... just curious as to what url you have in your general tab in settings? Also when you say hard coded the image - did you do something like this... <a href="https://panel.obedia.com/client_register/clientReg.cfm">img code here</a> as the code on your page is show you have a relative link which attaches the domain name you have in your general settings. hope this helps.. Al

  3. brianbotkiller
    Member
    Posted 1 year ago #

    Hey there,

    In my general settings, I have https://www.obedia.com set as the URL for the page.

    Yeah - when I hardcoded, my code is a normal hyperlink, and is set to that location on my server - however, WP is randomly deciding to put https://www.obedia.com/ in front of panel.obedia.com - can't understand why.

    thanks for reading.

  4. brianbotkiller
    Member
    Posted 1 year ago #

    Ah! Figured it out. Hyperlink wasn't working quite properly. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic