WordPress.org

Ready to get started?Download WordPress

Forums

Ridizain
[resolved] Hyperlinks Don't Work (23 posts)

  1. cessanfrancsico
    Member
    Posted 5 months ago #

    Hyperlinks aren't working.

    When I try to enter a hyperlink into a page, using the Text field, for example:

    <a href="http://www.apple.com>Apple</a>

    The word "Apple" appears on the page but it is unclickable.

    I've tried doing this manually and using the hyperlink buttons.

    Any suggestions?

    thanks

  2. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    You are missing the closing " marks on that code - works fine on my end with the code as..
    <a href="http://www.apple.com">Apple</a>

    Regards,
    Zulf

  3. cessanfrancsico
    Member
    Posted 5 months ago #

    Thanks!

    Yeah, I noticed that too. I corrected it but I am still not getting working hyperlinks.

    However, I did do some more troubleshooting and found that my problem is from a custom page template that I created.

    I wanted the pages, with the exception of the homepage, to not show any sidebars. I was able to achieve that with the custom page template but for some reason my hyperlinks are now not working.

    Hmmmmm...

    Any input or ideas would be greatly appreciated.

    Thanks.

  4. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    If you'd like to share the template code via pastebin I'll be more than happy to have look at it and see what the cause is.

  5. cessanfrancsico
    Member
    Posted 5 months ago #

    Thanks!

    I just pasted the code in pastebin. Let me know if you do or don't get it.

    Thanks!

  6. cessanfrancsico
    Member
    Posted 5 months ago #

    I changed the class "site-content" to "custom-site-content" and in a child-theme wrote this:

    .custom-site-content {
    width: 100%;
    float: left;
    }

    I did this because I wanted the text to fill the entire page.

    Thanks.

  7. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    Can I have the link please?

  8. cessanfrancsico
    Member
    Posted 5 months ago #

  9. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    I'm getting the "This website is currently under development." page with that link.

    Need the direct link to the pastebin.

  10. cessanfrancsico
    Member
    Posted 5 months ago #

    Sorry. Try it now.

  11. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    Still not being redirected to pastebin - just a page on the site with Simon & Turtle link.

    Lets try something else. Please create an account here and the drop a zip file of the templates in my dropbox: http://wpdefault.com/drop-share/

    Taking a break for a few hours but I'll check on it as soon as I'm back online and then get back to you.

    Zulf

  12. cessanfrancsico
    Member
    Posted 5 months ago #

    Thanks!

    I just created an account in pastebin and posted the template code.

    Let me know if you see it.

    Thanks.

  13. cessanfrancsico
    Member
    Posted 5 months ago #

    Unfortunately I am unable to register and set up an account at that link. But I did setup a pastebin account and I posted the code for the custom page template.

    Let me know if you need anything else.

    Thanks.

  14. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    Sorry but I can't get to the code unless you paste the pastebin link here

    Or you can give your profile that should look like this: http://pastebin.com/u/ridizain and I'll try and get to the code from there if its not marked private.

  15. cessanfrancsico
    Member
    Posted 5 months ago #

    <?php
    /**
     * Template Name: Custom Width Page
     *
     *
     * @package Ridizain
     * @since Ridizain 1.0
     */
    
    get_header(); ?>
    
    	<div id="primary" class="content-area">
    		<div id="content" class="custom-site-content" role="main">
    			<?php
    				// Start the Loop.
    				while ( have_posts() ) : the_post();
    
    					// Include the page content template.
    					get_template_part( 'content', 'page' );
    
    					// If comments are open or we have at least one comment, load up the comment template.
    					if ( comments_open() || get_comments_number() ) {
    						comments_template();
    					}
    				endwhile;
    			?>
    		</div><!-- #content -->
    	</div><!-- #primary -->
    </div><!-- #main-content -->
    
    <?php
    get_footer();
  16. cessanfrancsico
    Member
    Posted 5 months ago #

    Additionally, here is the pastebin link:

    http://pastebin.com/AxAmuHvd

    Thanks for your help

  17. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    OK got to the bottom of the issue.

    There's actually nothing wrong with the template and the code. The issue is the left sidebar or more precisely, the .site:before element which has a higher z-index and overlays that section of the page.

    The solution would be to run a function that is invoked when that template is use and will output the required CSS to remove the .site:before element.

    For code example, have a look at Fourteen Extended which has a function to do just that on per page basis.

  18. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    The output for the above function would then be something like

    function ridizain_general_css(){
    if ( get_post_meta(get_the_ID(), '_fourteenxt_true_fullwidth', true )) {
    if ( is_page_template( 'template-location/template-name.php' )) :
    ?>
    <style>
    .full-width .archive-header,
    .full-width .comments-area,
    .full-width .image-navigation,
    .full-width .page-header,
    .full-width .page-content,
    .full-width .post-navigation,
    .full-width .site-content .entry-header,
    .full-width .site-content .entry-content,
    .full-width .site-content .entry-summary,
    .full-width .site-content footer.entry-meta {
    	max-width: 1200px;
    	width: 100%;
    }
    .site:before,#secondary{width:0;display:none;}.ie8 .site:before,.ie8 #secondary{width:0px;display:none;}.featured-content{padding-left:0;}.site-content,.site-main .widecolumn{margin-left:0;}.ie8 .site-content,.ie8 .site-main .widecolumn{margin-left:0;}
    @media screen and (min-width: 1008px) {.search-box-wrapper{padding-left:0;}}@media screen and (min-width: 1080px) {.search-box-wrapper,.featured-content{padding-left:0;}}
    </style>
    <?php endif; }
    
    }
    add_action( 'wp_head', 'ridizain_general_css' );

    You'd add this code in your functions.php

  19. cessanfrancsico
    Member
    Posted 5 months ago #

    Great! Thanks so much.

    That is just a little over my head, but I should be able to read up and wrap my head around it.

    Thanks again!

  20. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    OK, let me work that in to the plugin - you'll be able to use the current full-width template included in the theme.

  21. cessanfrancsico
    Member
    Posted 5 months ago #

    Wow! You're developing on a plugin? Or do you mean an update?

    Let me know when it's available!

    thanks.

  22. Zulfikar Nore
    Member
    Theme Author

    Posted 5 months ago #

    Its a plugin :)

    And the first version is ready for download here: http://ridizain.com/ridizain-styles/

    You'll find the option you want on the edit page screen - by checking the box you'll be able to remove the left sidebar only on that page and thus making it a true 100% full width.

    Do let me know what you think. I appreciate all feedback :)

    Zulf

  23. cessanfrancsico
    Member
    Posted 5 months ago #

    Hey!

    So I installed the plugin and it works great!

    It's perfect!

    Thanks so much!

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.