WordPress.org

Ready to get started?Download WordPress

Forums

HungryFEED
[resolved] Hungry feed not working after update (12 posts)

  1. garygraefen
    Member
    Posted 1 year ago #

    I was dismayed because your system was rocking-then I got an update notice didi it and it stopped functioning entirely. I had many blogs with an rss after my content. And had to redo alot. Is ther anyway to get the older version which worked?-I really liked it. :)

    http://wordpress.org/extend/plugins/hungryfeed/

  2. Jason
    Member
    Plugin Author

    Posted 1 year ago #

    I would definitely like to know what error you received so I can fix the issue. Thanks!

  3. garygraefen
    Member
    Posted 1 year ago #

    I didn't get an error messages at all-after inserting the code all I got was a blank page-I am using wordpress 3.5
    Before I updated the version-it worked wonderfully. Search engines liked it. Since I am not a programmer-I was at a loss. I tried everything I could think of.

  4. garygraefen
    Member
    Posted 1 year ago #

    I will try reinstalling it again and see if I can get it to generate an error

  5. garygraefen
    Member
    Posted 1 year ago #

    Ok just so you do not freak out-I tried setting hungry feed cache to 0- suddenly the feeds appeared again. I am thinking it is all the caching going on in my system. Or perhaps an error in the hungry feed cache itself I much prefer hungry feed to others-If I encounter any more difficulty I will let you know-sometimes it would appear that I am not getting the feed from the called xml-Could be part of the problem

  6. Jason
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm, ok. I added in some better detection of the cache folder in the latest version so perhaps it caught that. Can you tell me your host and or server OS (Linux, Windows, etc?)

    Most likely you don't have a folder ~/wp-content/cache/ or else you do have that folder but the permissions don't allow writing. That would be better than disabling the cache.

  7. garygraefen
    Member
    Posted 1 year ago #

    I do not know what os my server uses-its called fatcow.com, its probably linux. The last time I tried to change permissions to a folder in my wordpress files the whole system crashed-and I had to have their support fix it. I will look to see if the folder is there. But since it is working I hesitate to do anything. I do want to thank you for your support in this matter-most people wouldn't care :) .I am using simple cache perhaps there is a conflict, Or as you say a permissions issue-I will look into it. Thank you very much for your time and help.

  8. Jason
    Member
    Plugin Author

    Posted 1 year ago #

    Not a problem. My guess is that there is an error occurring due to the cache folder permissions but your host has php error reporting disabled so all you see is a blank page instead of the actual error. The plugin is supposed to detect any problems and then show a friendly message with instructions. But, for whatever reason it's not catching that on your system. I'd definitely like to know where the crash is happening because, although most people don't have problems, when they do this seems to be the #1 issue. So it will be helpful for me if you are ever able to perhaps look at your php error logs or enable PHP error reporting. I can't reproduce it on another system. Thanks again.

  9. Peter Stolwijk
    Member
    Posted 11 months ago #

    Can you give any good advise, for my Cache Duration?
    Thank you sir.

  10. Jason
    Member
    Plugin Author

    Posted 11 months ago #

    I think the default of 3600 seconds (1 hour) is pretty reasonable.

    If you are displaying a feed that has fast real-time information then you might want to lower that.

    If you are displaying a feed that doesn't have new posts very often then you could increase it to longer, like 24 hours or something like that.

  11. Peter Stolwijk
    Member
    Posted 11 months ago #

    Would you please give me advise for my site then.

    Although now, every three minutes a news post arrives.
    Look for yourself: sneap.nl

    Thank you sir.

  12. Jason
    Member
    Plugin Author

    Posted 11 months ago #

    There is no correct answer. The best setting depends entirely on the purpose of your page and how much traffic you get.

    Do you want your page to update every 3 minutes? Or would it be OK if your page only updates one time per hour? If you want your page to update every 3 minutes, then you can set the cache to 180 seconds.

    long cache = feed items are sometimes stale, but your page load is usually fast

    short cache = feed items are always fresh, but your page load is usually slow

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags