WordPress.org

Ready to get started?Download WordPress

Forums

Hundreds Of Posts Have Lost Their Category Assignments, How To Repair? (4 posts)

  1. Mike Shupp
    Member
    Posted 1 year ago #

    WordPress version 3.4.2
    Thesis Theme version 1.8.5

    Hundreds of my posts have become uncategorized because of (I believe) a recent MYSQL server problem at my hosting provider... also, dozens of images aren't displaying in the Media Library...

    The hosting provider has restarted the MySQL server once, to no effect, and I'm waiting to hear back from them on further efforts. Other forum posts indicate a that a full "/tmp" directory (?) could be the cause, but hosting provider says that's not the issue here.

    The category admin panel in WP admin shows the correct post counts for each category, but once you click through one of them, only a few posts show as assigned to that category. Where is WP getting the post counts from?

    Where/how in the database are the category assignments stored? Does this issue sound like it can possibly still be resolved by getting any potential MySQL server communication errors fixed, or getting a /tmp/folder cleared? Or does it sound like data has been lost...?

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Categories will be referenced across multiple tables in the database. Do you have a recent database backup? Only it sounds like your current database has been damaged.

  3. Mike Shupp
    Member
    Posted 1 year ago #

    I have a database backup, not quite up-to-date, but probably 95% of my content. But yes, seems I can't try anything 'til I hear more from hosting provider...

  4. Mike Shupp
    Member
    Posted 1 year ago #

    Still waiting to hear more from hosting provider tech support... in the meantime, in exploring the database myself, and comparing to a 3-months-old retrieved version which is also on the server, I've found that the table <wp_term_relationships> has data that certainly does not look right to me:

    Link to old version screen shot

    Link to current version screen shot

    Does this look like the problem? Could just this table be restored?

Topic Closed

This topic has been closed to new replies.

About this Topic