WordPress.org

Ready to get started?Download WordPress

Forums

Human Error In Migrating Hosts (3 posts)

  1. klaraschmitt
    Member
    Posted 3 years ago #

    Hello,

    I have run aground in trying to move my WordPress site from one host to another. I have migrated sites before, but only in Drupal, and I find myself rather stuck at the moment. My hope is that if I lay all the circumstances on the table, someone might know what I did wrong. While I did find this lovely instructional page: http://codex.wordpress.org/Moving_WordPress. I found it too late to help me.

    So here's what I did. I backed up my site from my testing host http://www.klaraschmitt.com/carrollcountycloggers. I exported the MySQL database and imported it to Awardspace's phpMyAdmin 2.6.4-pl3
    by creating a new database and loading the exported file into it. I've perused the tables and the information looks liked it imported correctly.

    I then changed the wp-config.php file to reflect the new database name, host, and password. I uploaded my entire WordPress backup to the new server (Awardspace) at http://www.carrollcountycloggers.com. It was spitting out a database error (which I later determined to be because I'd put localhost instead of the correct server host in the config file). Because the transfer was causing downtime on the live site, I am now using a .htaccess to redirect users to the old website layout, while I troubleshoot the WordPress site. The .htaccess is in the root folder. I have 2 subfolders: OldWebsite and wordpress. I am currently working out of the wordpress folder.

    I resolved the database error and got a white screen on FireFox and an HTTP 500 Internal Server Error on IE. I googled that and figured out it was caused by my failure to change the URI in General Settings before moving the site. I found this article (http://www.wordpressmax.com/wordpress-guide/changed-wordpress-address-cant-login) and was able to login to my database > wp-options > siteurl and manually change it. I tried both using the root domain (when I had the files in the root domain) and also using http://www.carrollcountycloggers.com/wordpress (where all the wordpress files are sitting now). I still have the white screen/internal server error for both the index.php and the wp-login.php.

    And now I'm stuck and I would be extremely grateful to anyone who might know where I screwed up and what I ought to do to fix it. I don't know if the .htaccess is affecting it or not because I haven't had a lot of experience using those.

    Thanks in advance,
    Sincerely,
    Klara

  2. Tzeapa
    Member
    Posted 2 years ago #

    see if this helps http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory.

    It's usually a good idea to install wordpress in the root directory.

    /public_html/index.php rather than /public_html/wordpress/index.php but either way should work

  3. Sabinou
    Member
    Posted 2 years ago #

    Chances are also your database still keeps track of the previous hosting location and your blog engine is at a loss.

    I'd recommend using the "search" tab in phpmyadmin, to search in all the database tables for
    klaraschmitt.com, and manually edit all the keys having this problem.

    First one to change is the one in wp-options (if I recall it correctly) stating the blog home URL.
    Edit that one, perform the search again, and hopefully you'll have less occurences after this.

    If you have many entries to replace in the wp_posts table, then ask Lorelle :
    http://lorelle.wordpress.com/2005/12/01/search-and-replace-in-wordpress-mysql-database/

    I don't say this will solve all your problems, but it will solve a part of it at least :)

Topic Closed

This topic has been closed to new replies.

About this Topic