WordPress.org

Ready to get started?Download WordPress

Forums

Huge Special Characters problem (4 posts)

  1. krembo99
    Member
    Posted 2 years ago #

    I have a problem regarding special characters that are appearing messed up on the front-end . mainly the get converted to question marks, or something like �?)

    Example - Frédèric becomes Fr�d�ric.

    some facts that made me puzzled:

    • This WP install is on LOCAL machine, and shares the server with at
      least 40 other installs - none of which have this problem.
    • This WP install shares also the same DB as the others .
    • My wp-config file has the collate and charset defined.
    • The DB seems fine , because when I am viewing the post in the EDITOR (back end) - all is correct , the problem is only on the FRONT end .
    • The DB seems fine (2) , opening the post in phpMyAdmin and checking the direct value - all characters are fine .
    • This problem is NOT a browser/os encoding , it was checked in 4
      different machines, 3 OS, and 9 browsers..

    I have tried all the solutions which I know from past experience, which include :

    • checking the wp-config (it is ok, utf-8 defined, collate ok)
    • Checking the DB - all UTF-8
    • checking my header (<?php bloginfo('charset'); ?>) - that renders correctly as utf-8 with valid markup.
    • Open all theme files in my editor, convert encoding to UTF-8 without bom and save.

    Did i missed something ? Any Ideas ??

  2. vahyd
    Member
    Posted 2 years ago #

    May be the font specified in styles.css does not include the special characters. Have you tried changing the font.?

  3. krembo99
    Member
    Posted 2 years ago #

    Thanks for trying to help , but this is not a font problem ..

  4. Jorge
    Member
    Posted 2 years ago #

    I was experiencing problems like this too, turns out it was the character settings on my text editor.

    http://wordpress.org/support/topic/anyone-else-experiencing-this?replies=4

    I found that when I use a program like Notepad++, you need to set the charset to UNIX/UTF-8 to render the correct output.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic