WordPress.org

Ready to get started?Download WordPress

Forums

huge problem with firefox, and editing wordpress themes (4 posts)

  1. drp
    Member
    Posted 8 years ago #

    Hey gang,

    I select and edit my WordPress themes through a my host site, netfirms wordpress admin dialogue. But today, I used netfirms file manager to download a .php file to look at it in Dreamweaver. I clicked the 'download' button on the .php file in my file manager, and Firefox pops up it's 'downloads' dialogue. I hit 'open' for the file, and as expected Dreamweaver opened the file.

    The problem is, now when I want to go choose another them from the WordPress dialogue, instead of simply going to that page (themes, theme editor), Firefox tries to download the .php files! I've cleared all my download history. I've looked udner every option under downloads in Firefox, but I can't find anything.

    How do I get the Themes and Theme editors to work like they used to.

    BTW: I'm really new at all this, so nothing would be an obvious solution to me.

    Many thanks.

  2. lxg
    Member
    Posted 8 years ago #

    Aside from the fact that editing PHP files in a WYSIWYG editor is not the most intelligent thing to do (although I believe to remember that DW can handle that), I could imagine that the PHP tags have been converted to HTML characters and the PHP parser on your server doesn't interpret them anymore (just a vague guess). Could you possibly open one of the php files with a text editor and see if there are php tags?

  3. drp
    Member
    Posted 8 years ago #

    We'll, I didn't really mean to use DW to open the files. But I only looked at one in DW and never changed or uploaded the file. I think this has more to do with firefox file associations. I can edit any are in my WordPress admin just fine (ex. pages, links, options, etc), it's just the Themes and Theme Editor options all try to open independently through Firefox as a download.

  4. lxg
    Member
    Posted 8 years ago #

    Sorry, then it seems I got you wrong. But if this is about file associations, then it is not actually a browser problem. Would you possibly like to try a different browser, Opera for example? Or, you might find a hint when typing about:config into FF. I'm sorry I can't help more with that as I'm not using Firefox.

    Also, I don't understand the dubble post issue.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.