WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Huge amounts of junk data in wpseo_titles (3 posts)

  1. scottnelle
    Member
    Posted 4 months ago #

    I run a multisite network with a few hundred sites and I've seen this problem on three sites. I first noticed while using version xxx.

    I noticed in my log that a couple of sites were particularly slow. Upon investigating, I found that the cause was a serialized string with hundreds of thousands of pieces of junk data in the wp_options table for the affected blog, under the option name wpseo_titles. The data looked like this:

    a:211769:{s:14:"noindex-author";s:0:"";s:14:"disable-author";s:0:"";s:15:"noindex-archive";s:0:"";s:16:"noindex-category";s:0:"";s:16:"noindex-post_tag";s:0:"";s:19:"noindex-post_format";s:0:"";s:16:"noindex-subpages";s:0:"";s:12:"hide-rsdlink";s:0:"";s:14:"hide-feedlinks";s:0:"";s:16:"hide-wlwmanifest";s:0:"";s:14:"hide-shortlink";s:0:"";s:10:"title_test";b:1;s:7:"version";s:6:"1.4.19";s:11:"ignore_tour";s:6:"ignore";s:14:"tracking_popup";s:4:"done";s:14:"yoast_tracking";s:3:"off";s:10:"cleanslugs";s:2:"on";i:0;b:0;i:1;b:0;s:36:"post_types-attachment-not_in_sitemap";b:1;s:9:"opengraph";s:0:"";s:10:"fb_adminid";s:0:"";
    s:8:"fb_appid";s:0:"";i:2;b:0;i:3;b:0;i:4;b:0;i:5;b:0;i:6;b:0;i:7;
    b:0;i:8;b:0;i:9;b:0;i:10;b:0;i:11;b:0;i:12;b:0;i:13;b:0;i:14;b:0;
    i:15;b:0;i:16;b:0;i:17;b:0;i:18;b:0;i:19;b:0;i:20;b:0;i:21;b:0;i:22;
    b:0;i:23;b:0;i:24;b:0;i:25;b:0;i:26;b:0;i:27;b:0;i:28;b:0;i:29;b:0;
    i:30;b:0;i:31;b:0;i:32;b:0;i:33;b:0;i:34;b:0;i:35;b:0;i:36;b:0;i:37;
    b:0;i:38;b:0;i:39;b:0;i:40;b:0;i:41;b:0;i:42;b:0;i:43;b:0;i:44;b:0;
    i:45;b:0;i:46;b:0;i:47;b:0;i:48;b:0;i:49;b:0;i:50;b:0;i:51;b:0;i:52;
    b:0;i:53;b:0;i:54;b:0;i:55;b:0;i:56;b:0;i:57;b:0;i:58;b:0;i:59;b:0;
    i:60;b:0;i:61;b:0;i:62;b:0;i:63;b:0;i:64;b:0;i:65;b:0;i:66;b:0;i:67;
    b:0;i:68;b:0;i:69;b:0;i:70;b:0;i:71;b:0;i:72;b:0;i:73;b:0;i:74;b:0;
    i:75;b:0;i:76;b:0;i:77;b:0;i:78;b:0;i:79;b:0;i:80;b:0;i:81;b:0;i:82;
    b:0;i:83;b:0;i:84;b:0;i:85;b:0;i:86;b:0;i:87;b:0;i:88;b:0;i:89;b:0;
    i:90;b:0;i:91;b:0;i:92;b:0;i:93;b:0;i:94;b:0;i:95;b:0;i:96;b:0;i:97;
    b:0;i:98;b:0;i:99;b:0;i:100;b:0;i:101;b:0;i:102;b:0;i:103;b:0;i:104;
    b:0;i:105;b:0;i:106;b:0;i:107;b:0;i:108;b:0;i:109;b:0;i:110;b:0;
    i:111;b:0;i:112;b:0;i:113;b:0;i:114;b:0;i:115;b:0;i:116;b:0;i:117;
    b:0;i:118;b:0;i:119;b:0;i:120;b:0;i:121;b:0;i:122;b:0;i:123;b:0;
    i:124;b:0;i:125;b:0;i:126;b:0;i:127;b:0;i:128;b:0;i:129;b:0;i:130;
    b:0;i:131;b:0;i:132;b:0;i:133;b:0;i:134;b:0;i:135;b:0;i:136;b:0;
    i:137;b:0;i:138;b:0;i:139;b:0;i:140;b:0;i:141;b:0;i:142;b:0;i:143;
    b:0;i:144;b:0;i:145;b:0;i:146;b:0;i:147;b:0;i:148;b:0;i:149;b:0;
    i:150;b:0;i:151;b:0;i:152;b:0;i:153;b:0;i:154;b:0;i:155;b:0;i:156;
    b:0;i:157;b:0;i:158;b:0;i:159;b:0;i:160;b:0;i:161;b:0;i:162;b:0;
    i:163;b:0;i:164;b:0;i:165;b:0;i:166;b:0;i:167;b:0;i:168;b:0;i:169;
    b:0;i:170;b:0;i:171;b:0;i:172;b:0;i:173;b:0;i:174;b:0;i:175;b:0;
    i:176;b:0;i:177;b:0;i:178;b:0;i:179;b:0;i:180;b:0;i:181;b:0;i:182;
    b:0;i:183;b:0;i:184;b:0;i:185;b:0;i:186;b:0;i:187;b:0;i:188;b:0;
    i:189;b:0;i:190;b:0;i:191;b:0;i:192;b:0;i:193;b:0;i:194;b:0;i:195;
    b:0;i:196;b:0;i:197;b:0;i:198;b:0;i:199;b:0;i:200;b:0;i:201;b:0;
    i:202;b:0;i:203;b:0;i:204;b:0;i:205;b:0;i:206;b:0;i:207;b:0;i:208;
    b:0;i:209;b:0;i:210;b:0;i:211;b:0;i:212;b:0;i:213;b:0;i:214;b:0;
    i:215;b:0;i:216;b:0;i:217;b:0;i:218;b:0;i:219;b:0;i:220;b:0;i:221;
    b:0;i:222;b:0;i:223;b:0;i:224;b:0;i:225;b:0;i:226;b:0;i:227;b:0;
    i:228;b:0;i:229;b:0;i:230;b:0;i:231;b:0;i:232;b:0;i:233;b:0;i:234;
    b:0;i:235;b:0;i:236;b:0;i:237;b:0;i:238;b:0;i:239;b:0;i:240;b:0;
    i:241;b:0;i:242;b:0;i:243;b:0;i:244;b:0;i:245;b:0;i:246;b:0;i:247;
    b:0;i:248;b:0;i:249;b:0;i:250;b:0;[...]

    it continued on in that fashion for up to 211769 serialized items.

    Before I identified the root cause it brought my entire server to its knees for several days because apache processes were being used up until timeout trying to load the data. I'm hoping to avoid the problem for the future.

    Anyone seen anything like this? Anyone know if it still happens in 1.5.2.5? I haven't been able to reproduce it, but as it seems to happen so infrequently I'm not sure how, exactly, I'd trigger it.

    Thanks for any insight!

    https://wordpress.org/plugins/wordpress-seo/

  2. jrf
    Member
    Posted 4 months ago #

    1. just a guess, but are you using WPML ? I've heard of other people with similar issues who were using WPML.
    2. v1.5+ cleans out the wpseo options so they only contain valid entries, so the above invalid ones would be removed on upgrade.

  3. scottnelle
    Member
    Posted 4 months ago #

    Hey JRF,
    1. Nope, not using WPML
    2. That's great news! I had just recently upgraded to 1.5.2.5 from 1.4.something when I posted. With luck, this will just never be a problem again.

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic