WordPress.org

Ready to get started?Download WordPress

Forums

Hupso Share Buttons for Twitter, Facebook & Google+
[resolved] HTTPS problem: insecure URL (5 posts)

  1. relax_nl
    Member
    Posted 1 year ago #

    My blog uses an SSL certificate. On the pages where the share buttons are visible the HTTPS protocol is dropped because some of the elements in the page refer to insecure URLs (like the remote images and the js files).
    A solution would be to install all these elements locally.

    See for example http://whynopadlock.com/ and try to examine the page burroesalvia.net/about

    http://wordpress.org/extend/plugins/hupso-share-buttons-for-twitter-facebook-google/

  2. kasal
    Member
    Plugin Author

    Posted 1 year ago #

    I will update the plugin to automatically use https urls when used on https website.

  3. kasal
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed in version 3.9.6.

  4. relax_nl
    Member
    Posted 1 year ago #

    Thank you, but I decided to switch to a plugin where resources are stored locally on my machine (less lag and more control).

  5. kasal
    Member
    Plugin Author

    Posted 1 year ago #

    You can also load all the images from your local WP installation with this plugin if you want.

    Go to plugin settings. Under "Use custom social share icons" select "Yes, serve images from local WordPress folder".

    You can also use another server or CDN if you want.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic